Skip to content

Commit

Permalink
dev-python/wrapt: add version 1.10.8
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Alex Brandt committed Apr 24, 2016
1 parent e3cc806 commit 3a58ce9
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/wrapt/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST wrapt-1.10.5.tar.gz 119157 SHA256 4fd82193b23f60e1a39f3e10c81143c1e29e26cd5
DIST wrapt-1.10.6-r1.tar.gz 120259 SHA256 b540e23753d3f7017ec0d38f16daf77f9e9cf170d5040abc3d87573ba20fc4f3 SHA512 658c780971dddf444070b9d30a8ac7c08ee0088b8f4378bcc9c22126608e52b338dc00969b08828b0318070abcf0e875bc2b7c6228a71fbbca362033088b4314 WHIRLPOOL 7aed77677a1448d6b3795be7fb56989be98a691a7470096adf45002ca124a99b5cab3e42b319493b4c8300684e488a07cf96d1c5a01e9fc9f181f765a0542254
DIST wrapt-1.10.6.tar.gz 25134 SHA256 9576869bb74a43cbb36ee39dc3584e6830b8e5c788e83edf0a397eba807734ab SHA512 d0c326fd401bc84656d69ec5da446b459f5596873a1ec01d616bebcc3d11237949eaafcfdf5de78e43f59927a0eaeee3da3f462975fa46fa22fd6c1593509e04 WHIRLPOOL 2d3c56d0a6e9e9af0a59708ce70190097da2459d80bdaa8d8f884a849905b44cdfb6bedb412ccd1e74be1e975492309a398e05d4b6c61a6852d3cd125230846a
DIST wrapt-1.10.7.tar.gz 120316 SHA256 50ad31f01761410b192ce054aebcb61c54dbd493446440214356635874ecafca SHA512 ca694963860e22d6fe05fdd679f25c7d2fb01a3a635f9744dd2034c7468563f299442a3a60f4385e049b15f04bc86c7c0a6d0501bf274a87cdcd786fd46efeee WHIRLPOOL 659226504f1711749dae0228a9de07bebd04d2c4dd4b8696095eb7e76c6e1a7e991ea5a08188d93abe14c8a7e9b69b0d4ea04945fcf8349dd1f397870e39cab1
DIST wrapt-1.10.8.tar.gz 120359 SHA256 096b47f44e3197934ccc335c53d2d21bf6ed9fd941b294726e26a1fd18fd4541 SHA512 2a37584b3c3a33a2d39d5cbe9f7e61a50131db55ffd5be7902b5ee84c347d8ff4d6094e5639d2f854fab274b2517a0e47420da9f543f11cf92973acd6d15d42e WHIRLPOOL 5f27b048b9f06c03c3e3acdd9c3a64308958585deb7e314c80158910cfc1eac154540a0e4a3c838718456d5ed38751d85f49645e634a7d2734cad916547a5bc7
47 changes: 47 additions & 0 deletions dev-python/wrapt/wrapt-1.10.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Module for decorators, wrappers and monkey patching"
HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc test"

DEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
"
RDEPEND=""

python_compile_all() {
use doc && emake -C docs html
}

python_compile() {
local WRAPT_EXTENSIONS=true

distutils-r1_python_compile
}

python_test() {
py.test -vv || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit 3a58ce9

Please sign in to comment.