Skip to content

Commit

Permalink
dev-python/mkdocs-material: Bump to 9.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 4, 2023
1 parent 88f1bb3 commit 3a6b792
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/mkdocs-material/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mkdocs-material-8.5.11.gh.tar.gz 10423819 BLAKE2B 8af9b10fde57a6543d86dc8d6004cb100359e274072486094e7db4f8eeb7d44d83505d00b3f202f02e695a613ae8e2fdf08ac1b39584e7d9aeae430bb560d60a SHA512 7fdc06cf7f64a2831fe2acb05a735bc9519fdf109fbccd5ee1667d07175916fffb295ccfa88a4352a7a0688f0eaf535c26ab49463f672d964d4a87ad8de6ddf1
DIST mkdocs-material-9.0.1.gh.tar.gz 10585027 BLAKE2B 7515e9820466e375098781f1bdcdb56f6f9616ef827fb307fbec2c696d28923837df8a7a93fb4972eaf8de82411c5287bc6d40e9d0e91f0a1f109e4ee35c7771 SHA512 800f02a9ec31e9505ce9092abcfb2558bf9edc2423c844f0acadb96f190ff858df3a74a704081eea8c1eec2851265d22b19a7d8d7aef49d3582f2c7ea05f9d60
DIST mkdocs-material-9.0.2.gh.tar.gz 10585323 BLAKE2B 2dec935eddcd3865709f9d571a6e7e13774d88b7960fd1f12e1bfc3b7b70c996ac1b6e7d6da74305a693f0104ebeb5ac4b1d9d84682fcc0195346713b014a663 SHA512 fe789f02e306d7279d2b9e3c2fef0301791bc9f109df12a217a42d4334c891702472a1fa28a98741e670a534963175d926fc76f725cb4f56be4d3f49906ab4d5
53 changes: 53 additions & 0 deletions dev-python/mkdocs-material/mkdocs-material-9.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{8..11} )

DOCS_BUILDER="mkdocs"
DOCS_DEPEND="
dev-python/mkdocs-material-extensions
dev-python/mkdocs-minify-plugin
dev-python/mkdocs-redirects
"

inherit distutils-r1 docs

DESCRIPTION="A Material Design theme for MkDocs"
HOMEPAGE="
https://github.com/squidfunk/mkdocs-material/
https://pypi.org/project/mkdocs-material/
"
SRC_URI="
https://github.com/squidfunk/${PN}/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"

RDEPEND="
>=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
>=dev-python/markdown-3.2[${PYTHON_USEDEP}]
>=dev-python/mkdocs-1.4.2[${PYTHON_USEDEP}]
>=dev-python/pygments-2.14[${PYTHON_USEDEP}]
>=dev-python/pymdown-extensions-9.9[${PYTHON_USEDEP}]
"

# mkdocs-material-extensions depends on mkdocs-material creating a circular dep
PDEPEND="
>=dev-python/mkdocs-material-extensions-1.1.0[${PYTHON_USEDEP}]
"

PATCHES=(
# simplify pyproject to remove extra deps for metadata
"${FILESDIR}/${PN}-8.5.7-simplify-build.patch"
)

src_prepare() {
echo "__version__ = '${PV}'" > gentoo_version.py || die
distutils-r1_src_prepare
}

0 comments on commit 3a6b792

Please sign in to comment.