Skip to content

Commit

Permalink
media-libs/libcdr: Fix build with boost-1.59 (bug 574120)
Browse files Browse the repository at this point in the history
KEYWORDS: Dropped ppc (missing in librevenge)
Also drop base.eclass

Package-Manager: portage-2.2.27
  • Loading branch information
a17r authored and akhuettel committed Feb 22, 2016
1 parent 129d2ee commit 3bbf650
Show file tree
Hide file tree
Showing 5 changed files with 52 additions and 18 deletions.
32 changes: 32 additions & 0 deletions media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 882a4b3f83a4b5097da53670c720a26f4e2750eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <[email protected]>
Date: Sun, 13 Dec 2015 20:37:16 +0100
Subject: [PATCH] Some boost 1.59 fixes

Change-Id: I0054c977a6d8ff5a9b93c147578e890476365999
---
src/lib/Makefile.am | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 3f00cc5..e14fa8c 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -13,8 +13,16 @@ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_include_HEADERS = \
$(top_srcdir)/inc/libcdr/CDRDocument.h \
$(top_srcdir)/inc/libcdr/CMXDocument.h

-AM_CXXFLAGS = -I$(top_srcdir)/inc $(REVENGE_CFLAGS) $(LCMS2_CFLAGS) $(ZLIB_CFLAGS) $(ICU_CFLAGS) $(DEBUG_CXXFLAGS) -DLIBCDR_BUILD=1
+AM_CXXFLAGS = -I$(top_srcdir)/inc \
+ $(REVENGE_CFLAGS) \
+ $(LCMS2_CFLAGS) \
+ $(ZLIB_CFLAGS) \
+ $(ICU_CFLAGS) \
+ $(DEBUG_CXXFLAGS) \
+ -DLIBCDR_BUILD=1 \
+ -DBOOST_ERROR_CODE_HEADER_ONLY \
+ -DBOOST_SYSTEM_NO_DEPRECATED

libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LIBADD = $(REVENGE_LIBS) $(LCMS2_LIBS) $(ZLIB_LIBS) $(ICU_LIBS) @LIBCDR_WIN32_RESOURCE@
libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_DEPENDENCIES = @LIBCDR_WIN32_RESOURCE@
libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined
11 changes: 6 additions & 5 deletions media-libs/libcdr/libcdr-0.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
inherit autotools eutils
[[ ${PV} == 9999 ]] && inherit git-r3

DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
Expand All @@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
"

src_prepare() {
base_src_prepare
epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
epatch_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
eautoreconf
}

src_configure() {
Expand Down
11 changes: 6 additions & 5 deletions media-libs/libcdr/libcdr-0.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
inherit autotools eutils
[[ ${PV} == 9999 ]] && inherit git-r3

DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
Expand All @@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
"

src_prepare() {
base_src_prepare
epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
epatch_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
eautoreconf
}

src_configure() {
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
inherit eutils
[[ ${PV} == 9999 ]] && inherit autotools git-r3

DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
Expand All @@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
"

src_prepare() {
base_src_prepare
eapply_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
}
Expand Down
8 changes: 4 additions & 4 deletions media-libs/libcdr/libcdr-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
inherit eutils
[[ ${PV} == 9999 ]] && inherit autotools git-r3

DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
Expand All @@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
"

src_prepare() {
base_src_prepare
eapply_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
}
Expand Down

0 comments on commit 3bbf650

Please sign in to comment.