forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-im/signal-desktop-bin: add 7.19.0
Signed-off-by: Robert Siebeck <[email protected]> Signed-off-by: Eli Schwartz <[email protected]>
- Loading branch information
1 parent
110127a
commit 3bdb0f0
Showing
2 changed files
with
97 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST signal-desktop_7.18.0_amd64.deb 121822236 BLAKE2B 849feabef50c63de609603aa6de10826214f98c72549761420c7be58b4c87cb7c5f5d36447c4fcb1159d2c2218eae34e3e84972b39631308f8d31351c7720cdf SHA512 4f6cb4408bbe529d5e56d0132212406ec6b313aa3074a06f666c8998ec97629ce1ff2796f97b070e6973a9e5e489c3210d8a53ec1d422069bd1cc6a958daf2a9 | ||
DIST signal-desktop_7.19.0_amd64.deb 121595302 BLAKE2B 24d86f4a622abc4b93a713debce12e4709fcc1e9b215ad560394454c951c9ff319b1ee373316645017b0d680bf1bde458848d3abe7f38dbb0d3f313b7028dc44 SHA512 03a573d12e30489ebd6a89062fbb88ff82ad7bcaadb29185af75911eff2a8be3fa30898035c79220560bde1f71db5ab71f74acb56ca99f8e721a23ab6289ac7e |
96 changes: 96 additions & 0 deletions
96
net-im/signal-desktop-bin/signal-desktop-bin-7.19.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
MY_PN="${PN/-bin/}" | ||
|
||
inherit pax-utils unpacker xdg | ||
|
||
DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer" | ||
HOMEPAGE="https://signal.org/ | ||
https://github.com/signalapp/Signal-Desktop" | ||
SRC_URI="https://updates.signal.org/desktop/apt/pool/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb" | ||
S="${WORKDIR}" | ||
|
||
LICENSE="GPL-3 MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 ISC openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="-* amd64" | ||
IUSE="+sound" | ||
RESTRICT="splitdebug" | ||
|
||
RDEPEND=" | ||
>=app-accessibility/at-spi2-core-2.46.0:2 | ||
dev-libs/expat | ||
dev-libs/glib:2 | ||
dev-libs/nspr | ||
dev-libs/nss | ||
>=media-fonts/noto-emoji-20231130 | ||
media-libs/alsa-lib | ||
media-libs/mesa[X(+)] | ||
net-print/cups | ||
sys-apps/dbus[X] | ||
x11-libs/cairo | ||
x11-libs/gtk+:3[X] | ||
x11-libs/libdrm | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libxkbcommon | ||
x11-libs/libXcomposite | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXrandr | ||
x11-libs/pango | ||
sound? ( | ||
|| ( | ||
media-libs/libpulse | ||
media-sound/apulse | ||
) | ||
) | ||
" | ||
|
||
QA_PREBUILT=" | ||
opt/Signal/chrome_crashpad_handler | ||
opt/Signal/chrome-sandbox | ||
opt/Signal/libEGL.so | ||
opt/Signal/libGLESv2.so | ||
opt/Signal/libffmpeg.so | ||
opt/Signal/libvk_swiftshader.so | ||
opt/Signal/libvulkan.so.1 | ||
opt/Signal/resources/app.asar.unpacked/node_modules/* | ||
opt/Signal/signal-desktop | ||
opt/Signal/swiftshader/libEGL.so | ||
opt/Signal/swiftshader/libGLESv2.so" | ||
|
||
src_prepare() { | ||
default | ||
sed -e 's| --no-sandbox||g' \ | ||
-i usr/share/applications/signal-desktop.desktop || die | ||
unpack usr/share/doc/signal-desktop/changelog.gz | ||
} | ||
|
||
src_install() { | ||
insinto / | ||
dodoc changelog | ||
doins -r opt | ||
insinto /usr/share | ||
|
||
if has_version media-sound/apulse[-sdk] && ! has_version media-sound/pulseaudio; then | ||
sed -i 's/Exec=/Exec=apulse /g' usr/share/applications/signal-desktop.desktop || die | ||
fi | ||
|
||
doins -r usr/share/applications | ||
doins -r usr/share/icons | ||
fperms +x /opt/Signal/signal-desktop /opt/Signal/chrome-sandbox /opt/Signal/chrome_crashpad_handler | ||
fperms u+s /opt/Signal/chrome-sandbox | ||
pax-mark m opt/Signal/signal-desktop opt/Signal/chrome-sandbox opt/Signal/chrome_crashpad_handler | ||
|
||
dosym -r /opt/Signal/${MY_PN} /usr/bin/${MY_PN} | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
elog "For using the tray icon on compatible desktop environments, start Signal with" | ||
elog " '--start-in-tray' or '--use-tray-icon'." | ||
} |