forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-misc/matchbox-keyboard: fix .desktop qa warn
Patches desktop file to resolve QA warning, bump to EAPI6. Ebuild and patch from user popham to resolve bug. Gentoo-bug: 434704 Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
11 changes: 11 additions & 0 deletions
11
x11-misc/matchbox-keyboard/files/matchbox-keyboard-0.1-r1-modernize_desktop.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/matchbox-keyboard.desktop | ||
+++ b/matchbox-keyboard.desktop | ||
@@ -3,6 +3,6 @@ | ||
Comment=Virtual Keyboard | ||
Exec=matchbox-keyboard | ||
Type=Application | ||
-Icon=matchbox-keyboard.png | ||
-Categories=Panel;Utility;MB | ||
+Icon=matchbox-keyboard | ||
+Categories=Utility;X-MB;X-Panel; | ||
X-MB-INPUT-MECHANSIM=True |
28 changes: 28 additions & 0 deletions
28
x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="6" | ||
|
||
inherit versionator eutils | ||
|
||
DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard" | ||
HOMEPAGE="http://matchbox-project.org/" | ||
SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86" | ||
IUSE="debug cairo" | ||
|
||
DOCS=( AUTHORS ChangeLog INSTALL NEWS README ) | ||
PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch ) | ||
|
||
DEPEND="x11-libs/libfakekey | ||
cairo? ( x11-libs/cairo[X] ) | ||
!cairo? ( x11-libs/libXft )" | ||
RDEPEND="$DEPEND" | ||
|
||
src_configure() { | ||
econf $(use_enable debug) $(use_enable cairo) | ||
} |