Skip to content

Commit

Permalink
dev-cpp/cpp-hocon: updating deps more in line with the actual code
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
prometheanfire committed Nov 11, 2016
1 parent 5d778c4 commit 3c4631f
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/cpp-hocon/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cpp-hocon-0.1.2.tar.gz 150618 SHA256 28ef85d03df9413bb86ba313622d85bcc5b9fca4212bf9581c017a3ae526e874 SHA512 19081ee6d415a175bade38e5061bb06c60a1c8e886b2c395ddaa3a601b8f7928e76a6773c136387b9d5e2784dd9a0696ff183f277f32d8e636eb335d6155aadc WHIRLPOOL fb2d52a0bf7f70d3350090b85e9c25355e4c2229e5083c5830bd6b919b99406ec32bc47e6fc5a830c4e6e610cb0792234cf1cdea1b40cd70bb448abb69ba6cdd
DIST cpp-hocon-0.1.4.tar.gz 157988 SHA256 2274b99dc098122b6e3d2c8d23173d21893555190c5a008e5a9a7d84875c7275 SHA512 f5ee6c5e7eaa5139bb3c421fd8b7c0da337daec99dce7f426d567ced0036b7c49a396b1b9bdbaa8023cd776a5a942175082a4b30280d4211a0db51483324be42 WHIRLPOOL a9a4f677dc708d5097812ca407257c9f44168d36081d5a55d32d10862555fa89f213208b0e5c3e83900b1e8c7b313c4ba66e7684f9ba0b5c3b01f0a1ae8f1d6a
44 changes: 44 additions & 0 deletions dev-cpp/cpp-hocon/cpp-hocon-0.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils

DESCRIPTION="Provides C++ support for the HOCON configuration file format"
HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="debug test"

DEPEND="
>=sys-devel/gcc-4.9.3:*
>=dev-libs/boost-1.54[nls]
>=dev-libs/leatherman-0.9.3
"
RDEPEND="${DEPEND}"

src_prepare() {
default
# make it support multilib
sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
}

src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
)
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

0 comments on commit 3c4631f

Please sign in to comment.