forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libmediainfo: version bump to 0.7.81
- Loading branch information
Showing
2 changed files
with
80 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST libmediainfo_0.7.73.tar.bz2 1648742 SHA256 d350dbbdc25a52f79bcb3d5e91d0a61c68a4f429c13c80166d2e37476a62feb0 SHA512 44e4d5089e4343e503117a6e125e324551ecdc8e3ec01523dd13a66652708d2f0e8e1ab1740754524f0b9847ba317f97f123034bf0b06216ad3e60b5d0f56908 WHIRLPOOL 496e463691410bf8350c31e63e5268dc2974a6b4c9fb80661d80d8738d299f3a5813044cf5057db32aa09639cc365c347c677c0c7ce759f1b953c47fd9b379c0 | ||
DIST libmediainfo_0.7.80.tar.xz 1517248 SHA256 e587b6aac746ea08ba2bb269446ba8ff54d253cb2172fc8ee9b3818ecfe8376d SHA512 49fb59c28acdc908e6629085d5a6136d57e689ded71312d286cf163597b11b617222ac5aee0c45142f352083b1fdca7caa23bff825726198c6406077b1d9f21c WHIRLPOOL a8f7029d9533eda7a64fc5a1c735b30a3b491a6ab4706622254c46ed17b447a634df38fcf6b88f551b354c18da8f62af2706d6b23ecbed6408909f8527e375ff | ||
DIST libmediainfo_0.7.81.tar.xz 1522456 SHA256 9a01b5e9899ce10df5745553bef8381dcda0e367fd568804e696f263cfcbee43 SHA512 7fdc72df7ded6f463b89495e64ccb2da68c48471990d15e56cd197d82182332c1b64305cf5d77ddf67a36eab29074d11a26439fb386ee9ab149dfde0badf6fc3 WHIRLPOOL 0651164bc5dddf872e67d1591f70f00cfde0530005f96681d1d750386882c41fa1aa83bc8efd2cdf828a9e08121869ac446bb93148a72d7e20eb00da0e41755a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit autotools eutils flag-o-matic multilib | ||
|
||
MY_PN="MediaInfo" | ||
DESCRIPTION="MediaInfo libraries" | ||
HOMEPAGE="http://mediaarea.net/mediainfo/" | ||
SRC_URI="http://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="curl doc mms static-libs" | ||
|
||
RDEPEND="sys-libs/zlib | ||
dev-libs/tinyxml2:= | ||
>=media-libs/libzen-0.4.28[static-libs=] | ||
curl? ( net-misc/curl ) | ||
mms? ( >=media-libs/libmms-0.6.1[static-libs=] )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen )" | ||
|
||
S=${WORKDIR}/${MY_PN}Lib/Project/GNU/Library | ||
|
||
src_prepare() { | ||
sed -i 's:-O2::' configure.ac || die | ||
append-cppflags -DMEDIAINFO_LIBMMS_DESCRIBE_SUPPORT=0 | ||
|
||
epatch "${FILESDIR}"/${PN}-0.7.63-pkgconfig.patch | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--enable-shared \ | ||
--with-libtinyxml2 \ | ||
$(use_with curl libcurl) \ | ||
$(use_with mms libmms) \ | ||
$(use_enable static-libs static) \ | ||
$(use_enable static-libs staticlibs) | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use doc; then | ||
cd "${WORKDIR}"/${MY_PN}Lib/Source/Doc | ||
doxygen Doxyfile || die | ||
fi | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
edos2unix ${PN}.pc #414545 | ||
insinto /usr/$(get_libdir)/pkgconfig | ||
doins ${PN}.pc | ||
|
||
for x in ./ Archive Audio Duplicate Export Image Multiple Reader Tag Text Video; do | ||
insinto /usr/include/${MY_PN}/${x} | ||
doins "${WORKDIR}"/${MY_PN}Lib/Source/${MY_PN}/${x}/*.h | ||
done | ||
|
||
insinto /usr/include/${MY_PN}DLL | ||
doins "${WORKDIR}"/${MY_PN}Lib/Source/${MY_PN}DLL/*.h | ||
|
||
dodoc "${WORKDIR}"/${MY_PN}Lib/*.txt | ||
if use doc; then | ||
dohtml -r "${WORKDIR}"/${MY_PN}Lib/Doc/* | ||
fi | ||
|
||
prune_libtool_files | ||
} |