Skip to content

Commit

Permalink
dev-python/webob: 1.7.3 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
prometheanfire committed Aug 27, 2017
1 parent 005dfc4 commit 3c6df2c
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/webob/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST WebOb-1.4.tar.gz 633302 SHA256 0819838204e2a6823e42bf2227898fdf3f306f7619bf328e25855a0d1ca20399 SHA512 0cf1a21b7d863c355e445f0e9f898ffb1c4c39099532a86d830c1be5d84efc0c6f3e8151a283cfd1cb5bebcb1fe78a2b6b269cbc130863679a017565a2539a37 WHIRLPOOL abfc696b7f50a74edd3d84099365f802f5be0eddf56a1c128f6e026c30bdeddc1b58c6bb45d4281ee4fb3d7937888d8065b01f93a363c82cd9cd1834eb2378da
DIST WebOb-1.6.3.tar.gz 206375 SHA256 1b03115e162dd0102f6147c5d5ed71a3a2ba0f58ef829244b64f52fe6dbf5888 SHA512 41830571ca4e0727b2bb2c6ad81f36f2d07a2018c2a01e00acb2e32ef7c503e133653cb62f1ddcda3bf10f44ff3215cc2e2b53e7544b867ddf3f50fa9b4ca79b WHIRLPOOL 2bd99bbc0dece593c899aa962b8bfe7d35cd908fdc8723997cfd61250d6ac73b85c8d48a0b78fd162f591e941f8dfb74a7d21a11f12c750cb5f06d2736a64504
DIST WebOb-1.7.3.tar.gz 216028 SHA256 e65ca14b9f5ae5b031988ffc93f8b7f305ddfcf17a4c774ae0db47bcb3b87283 SHA512 23a51f184754c525dc293b8b71855d40f52445c0df5434af7ec091219e0ea81be162623157b6ec67214cd151b25014bf86991246785816ebcb5a0d1eec9479a1 WHIRLPOOL 3a90c00f17a09c5a44b3bd5e10dcb66f80d6f0348837864a8e58730a70a834e19316b73096be70c437db3d4f33123c31292794fcaafed301e02dda3f4c993b87
43 changes: 43 additions & 0 deletions dev-python/webob/webob-1.7.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )

inherit distutils-r1 versionator

MY_PN=WebOb
MY_P=${MY_PN}-${PV}

DESCRIPTION="WSGI request and response object"
HOMEPAGE="http://webob.org/ https://pypi.python.org/pypi/WebOb"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}] )"
RDEPEND=""

S=${WORKDIR}/${MY_P}

python_compile_all() {
if use doc; then
esetup.py build_sphinx
fi
}

python_test() {
nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
distutils-r1_python_install_all
}

0 comments on commit 3c6df2c

Please sign in to comment.