Skip to content

Commit

Permalink
gnome-base/nautilus: bump to 3.36.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
leio committed Jul 12, 2020
1 parent aea2afb commit 3c85c1e
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/nautilus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nautilus-3.34.3.tar.xz 3213260 BLAKE2B a417ee5d5e032befed704b71b9ffd29cc9a2a6fae0612f96601756b876b0990625cc78eb2c7679bdce914f3dd30208b60243f403a508cf87a6761ea56251140d SHA512 f8ef86b5b67ef2b8eced492ee6b8d77155a9d6ec5ba6bb18132d678e6f12870963da9bcf4ff0bfbb8f4791bf068314557f9551febc23234c48d722e529c6ed9d
DIST nautilus-3.36.3.tar.xz 3201908 BLAKE2B ec7be7ad523e29c853a1a16dd6381257bd7f7af0004d4b84a9ef13539f5c8ea431c61f819eee6c0d396037846d390ae112b3fe2771276cde6128e7fad95eb4f4 SHA512 4dce01c20a34ed9bbff53a9886775af431754d02a4300e4647d87830502103e7436e53127b2e503af8e3a90785aa864514dbde22508ffb3e06eb43d4633fddde
105 changes: 105 additions & 0 deletions gnome-base/nautilus/nautilus-3.36.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,105 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg

DESCRIPTION="Default file manager for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"

LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"

DEPEND="
>=dev-libs/glib-2.58.1:2
>=media-libs/gexiv2-0.10.0
gstreamer? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0 )
>=app-arch/gnome-autoar-0.2.1
>=gnome-base/gnome-desktop-3.0.0:3=
>=x11-libs/gtk+-3.22.27:3[X,introspection?]
>=x11-libs/pango-1.28.3
selinux? ( >=sys-libs/libselinux-2.0 )
>=app-misc/tracker-2.0:=
x11-libs/libX11
>=dev-libs/libxml2-2.7.8:2
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
"
RDEPEND="${DEPEND}
sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
gstreamer? ( !<media-video/totem-3.31.91[nautilus] )
>=app-misc/tracker-miners-2.0:=
" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
BDEPEND="
>=dev-util/gdbus-codegen-2.51.2
dev-util/glib-utils
gtk-doc? (
>=dev-util/gtk-doc-1.10
app-text/docbook-xml-dtd:4.1.2 )
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
x11-base/xorg-proto
"
PDEPEND="
gnome? ( x11-themes/adwaita-icon-theme )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
>=gnome-base/gvfs-1.14[gtk(+)]
" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34

PATCHES=(
"${FILESDIR}"/3.30.5-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc
"${FILESDIR}"/3.32.3-optional-gstreamer.patch # Allow controlling audio-video-properties build
)

src_prepare() {
if use previewer; then
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
To activate the previewer, select a file and press space; to
close the previewer, press space again."
fi
xdg_src_prepare
}

src_configure() {
local emesonargs=(
$(meson_use gtk-doc docs)
-Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
$(meson_use gstreamer) # gstreamer audio-video-properties extension
$(meson_use introspection)
-Dpackagekit=false
$(meson_use selinux)
-Dprofiling=false
-Dtests=$(usex test all none)
)
meson_src_configure
}

src_install() {
use previewer && readme.gentoo_create_doc
meson_src_install
}

src_test() {
virtx meson_src_test
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update

if use previewer; then
readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit 3c85c1e

Please sign in to comment.