Skip to content

Commit

Permalink
kde-plasma/plasma-firewall: 5.24.3 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 8, 2022
1 parent aee96d3 commit 3ca774f
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-plasma/plasma-firewall/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST plasma-firewall-5.23.5.tar.xz 344132 BLAKE2B 3277329f223f5b4afe33bcf663b8c9f999a8dda4cab593e04d57fb8b2d6d4d899f76f803ca6cc8e3ef718bbcb09f2cb6d24dbaa1c3abcbfa5e163dd791f066ca SHA512 c18b25ad85f57da80edfc03cd445d317162ad2f952fe7ecd09f43af274798acd965de0f8643a636bee74e3572f0ab66f3db876126009b9c98f486a1cfe0e386e
DIST plasma-firewall-5.24.2.tar.xz 345024 BLAKE2B 1ac4d8eb7a69033e98f4e4780b1e51e00d22dbeb321ac68c9a5122cd7dc04fcf46d6cb5427d048821433bc540df5517d42d27370b0220d266fc5fafab9d2a349 SHA512 030afa34dfe19dca1abba8d836ab09923a7049188b218f04ff7ea2abd36607d37ee5efa665f3a9b66423b2e66e3632ad8cab2cddb08067acfd1ce618dd86e014
DIST plasma-firewall-5.24.3.tar.xz 345048 BLAKE2B c7a7b03146cc03552cbb98bc9bef30677bf95bdc94b8182cdefc1f7626f2ab61cf7481cab4790bfa1902a3c35d37dcc8ba96e2c8d703be51f9bebf6f182d00ec SHA512 8e6c94bc591fae0e809e69df99ab4f7e96f45615fc8b6cb18dc6c3eca21b569a2f2e625b8faa4bea4c24d78e1e16d4590817b9e83ec5efb42e566ec434d51593
64 changes: 64 additions & 0 deletions kde-plasma/plasma-firewall/plasma-firewall-5.24.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
KFMIN=5.90.0
QTMIN=5.15.2
inherit ecm kde.org python-single-r1

DESCRIPTION="Plasma frontend for Firewalld or UFW"
HOMEPAGE="https://invent.kde.org/network/plasma-firewall"

LICENSE="GPL-2+"
SLOT="5"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
IUSE="firewalld +ufw"

REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"

DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtnetwork-${QTMIN}:5
>=dev-qt/qtx11extras-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/kauth-${KFMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kdeclarative-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/plasma-${KFMIN}:5
"
RDEPEND="${DEPEND}
${PYTHON_DEPS}
firewalld? ( net-firewall/firewalld )
ufw? ( net-firewall/ufw )
"

src_prepare() {
ecm_src_prepare
# this kind of cmake magic doesn't work for us at all.
sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
-i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
-DBUILD_UFW_BACKEND=$(usex ufw)
)
ecm_src_configure
}

pkg_postinst () {
ecm_pkg_postinst

if ! has_version sys-apps/systemd; then
ewarn "${PN} is not functional without sys-apps/systemd at this point."
ewarn "See also: https://bugs.gentoo.org/778527"
fi
}

0 comments on commit 3ca774f

Please sign in to comment.