Skip to content

Commit

Permalink
app-admin/sysstat: Versions 12.2.1 12.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Dec 27, 2019
1 parent b91bd05 commit 3ccfc58
Show file tree
Hide file tree
Showing 3 changed files with 164 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-admin/sysstat/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST sysstat-12.0.5.tar.gz 711967 BLAKE2B 96aa49d82e71407dbd99d840ca5f71af83f54ba6315c858fae71f97290e8cf9c4f5358ad6389c7489366a62667c35835151e3187382a56c98153d3a04bcc2b8d SHA512 c1061f1af35430e81e488e4b2f18b8588ec4f3c419ade004c49ca24baf60b5b76a6a59eb25f3b17b51a9f60c5833a914a514872d0235b2ca405341a2f4a32cb3
DIST sysstat-12.0.6.tar.gz 712148 BLAKE2B 1118ce071e06c2853ffdec2be1b8b3bf060571caf988e17e04ff62cbf43e7111c5951a131d176b49ad35e1da75d2b8936e23f1a385e1c83a013b802a0fc36003 SHA512 e8f542b26c2b0b7b3aadbf34dce640879d27f8f1659447f15ffb5a210987c74840418046409403da85a9eb4c01484615d230ddc700611b7c0088d72165bffe86
DIST sysstat-12.2.0.tar.gz 1227684 BLAKE2B 1ca5cc3f0fd5dca6655d7b483fa853bf9f0256ae5e8dabf56f698d736faadd38f64af699158f4d637d7c8564f12b0992d866e503d01c647be274fc87ee04a9b4 SHA512 2398be1d5181616c337ead8f62b6bfb1144b89c747800140503c6a94793976f7909c81b656290577d51ebdee2f380418902846271b48ed79c6d7f02306f0a8a1
DIST sysstat-12.2.1.tar.gz 1227707 BLAKE2B 566382d83a0230517d22e2630a9cb1aa631d761c914188a4e7fb15eddaedbd25b8a3dffa9893b1b2bbcc31d87a37cbe11b2b50ab0ec94a28f84018685d1b35c8 SHA512 a19d0978eb11071c228462cda496a59721541e57a1d15cb2d0964f287ac2d50b5587fa5bc2b8fe6be2a1f00cbf2e7c3bc59db6494e3e8c1906aa81437b30d073
DIST sysstat-12.3.1.tar.gz 1245248 BLAKE2B 69848c452642be992c7b4af33268c0d6b30f16e5ea44ec13b00ab57e6ec3b498d92b707a53757de9066138a9ee92b995765f44f75f692e1b3c68d829519d53ca SHA512 f67a2dac22748217687bd7f58521c0719754f13298fb5faed8a6d58c2bb1f8620428191d0415e816eea07bb3ca81453e057d03c7db0096430ad7d6ba6b7b611e
81 changes: 81 additions & 0 deletions app-admin/sysstat/sysstat-12.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm-sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm-sensors? ( sys-apps/lm-sensors:= )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-11.0.4-cron.patch
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/lib/sa \
conf_dir=/etc \
econf \
$(use_enable lm-sensors sensors) \
$(use_enable nls) \
$(usex debug --enable-debuginfo '') \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm "${D}"/usr/share/doc/${PF}/COPYING || die
}
81 changes: 81 additions & 0 deletions app-admin/sysstat/sysstat-12.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
IUSE="debug nls lm-sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm-sensors? ( sys-apps/lm-sensors:= )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-11.0.4-cron.patch
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/lib/sa \
conf_dir=/etc \
econf \
$(use_enable lm-sensors sensors) \
$(use_enable nls) \
$(usex debug --enable-debuginfo '') \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm "${D}"/usr/share/doc/${PF}/COPYING || die
}

0 comments on commit 3ccfc58

Please sign in to comment.