Skip to content

Commit

Permalink
dev-cpp/libodb: Move config.install.chroot="${D}" to src_install.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/836043
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Mark Wright <[email protected]>
  • Loading branch information
markwright committed Mar 27, 2022
1 parent bdb4a7a commit 3d03e75
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
--- build2-toolchain-0.13.0-orig/build2/libbuild2/script/regex.cxx 2020-06-10 19:25:37.000000000 +1000
+++ build2-toolchain-0.13.0/build2/libbuild2/script/regex.cxx 2020-08-10 14:00:05.698012838 +1000
@@ -5,6 +5,35 @@

#include <libbuild2/script/regex.hxx>

+#if defined(_LIBCPP_VERSION)
+template <>
+void
+std::__1::__match_any_but_newline<build2::script::regex::line_char>::__exec(__state& __s) const
+{
+ if (__s.__current_ != __s.__last_)
+ {
+ switch (*__s.__current_)
+ {
+ case '\r':
+ case '\n':
+ __s.__do_ = __state::__reject;
+ __s.__node_ = nullptr;
+ break;
+ default:
+ __s.__do_ = __state::__accept_and_consume;
+ ++__s.__current_;
+ __s.__node_ = this->first();
+ break;
+ }
+ }
+ else
+ {
+ __s.__do_ = __state::__reject;
+ __s.__node_ = nullptr;
+ }
+}
+#endif
+
using namespace std;

namespace build2
7 changes: 4 additions & 3 deletions dev-cpp/libodb/libodb-2.5.0_beta19.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -45,6 +45,7 @@ b() {
src_prepare() {
pushd "${BS}" || die
eapply "${FILESDIR}"/build2-0.13.0_alpha0_pre20200710-nousrlocal.patch
eapply "${FILESDIR}"/build2-0.13.0-libcpp-undefined-symol-vtable-for-match_any_but_newline-exec.patch
printf 'cxx.libs += %s\ncxx.poptions += %s\n' \
"-L${EPREFIX}/usr/$(get_libdir) $($(tc-getPKG_CONFIG) sqlite3 --libs)" \
"$($(tc-getPKG_CONFIG) sqlite3 --cflags)" >> \
Expand Down Expand Up @@ -91,7 +92,6 @@ src_configure() {
config.bin.ar="$(tc-getAR)" \
config.bin.ranlib="$(tc-getRANLIB)" \
config.bin.lib=shared \
config.install.chroot="${D}" \
config.install.root="${EPREFIX}"/usr \
config.install.lib="${EPREFIX}"/usr/$(get_libdir) \
config.install.doc="${EPREFIX}"/usr/share/doc/${PF}
Expand All @@ -107,5 +107,6 @@ src_test() {
}

src_install() {
b install
b install \
config.install.chroot="${D}"
}

0 comments on commit 3d03e75

Please sign in to comment.