Skip to content

Commit

Permalink
sys-cluster/heat: bup
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
prometheanfire committed Nov 22, 2016
1 parent 1e1a782 commit 3d07181
Show file tree
Hide file tree
Showing 2 changed files with 153 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/heat/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST heat-7.0.0.tar.gz 2269393 SHA256 16db746d540cee87170ec1fa6fdca945b6d2ead91b39e59f4d2d4a4c1d69e2db SHA512 23026d56e871bb8d86b0020678c4a0233ec63d4b16d338e089f4e594f1814d8581c5c46f3035993934711e34beccc18acb350e85e98675f52aba6e194f3de3fc WHIRLPOOL 08c87c89597c3f92ccc8cb96888f53b27ac44a46b245ab5b993c96b34446330df76dc098f26ab5dcd2d46970052315ead7b93ad3a44855a4f17f46d694a624d8
DIST heat-7.0.1.tar.gz 2247183 SHA256 215637bf3643ac5a39fb2594559d871e8e3996a8bd80e9677b724a9ba58427b2 SHA512 bc5fdb2ad5298bae41bfa4ea369748543e0d644fdf0c0c9ac1d2d55e25eb6db634cfde31abbe2d1207f17a98339cbf60efd95b6a760aaa7e2381f2baf7ae6955 WHIRLPOOL 1875ab1f2d6a4306ad0b49631b5b2012c2a3795f94e94266f64efc5fa63c7358ab0b5f21b5db4933759255e515a7476efec388c6efe83a7fc9ef58388bc05242
152 changes: 152 additions & 0 deletions sys-cluster/heat/heat-7.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,152 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1 eutils user

DESCRIPTION="A CloudFormation-compatible openstack-native cloud orchistration engine."
HOMEPAGE="https://launchpad.net/heat"
SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+mysql +memcached postgres sqlite"
REQUIRED_USE="|| ( mysql postgres sqlite )"

CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
app-admin/sudo"

RDEPEND="
${CDEPEND}
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
>=dev-python/croniter-0.3.4[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
!~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}]
>=dev-python/keystonemiddleware-4.0.0[${PYTHON_USEDEP}]
!~dev-python/keystonemiddleware-4.1.0[${PYTHON_USEDEP}]
!~dev-python/keystonemiddleware-4.5.0[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
!~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
>=dev-python/oslo-cache-1.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.9.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-4.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-4.13.1[${PYTHON_USEDEP}]
>=dev-python/oslo-db-4.13.2[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
>=dev-python/oslo-messaging-5.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-policy-1.9.0[${PYTHON_USEDEP}]
>=dev-python/oslo-reports-0.6.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
>=dev-python/oslo-versionedobjects-1.13.0[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
>=dev-python/aodhclient-0.5.0[${PYTHON_USEDEP}]
>=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
>=dev-python/python-ceilometerclient-2.5.0[${PYTHON_USEDEP}]
>=dev-python/python-cinderclient-1.6.0[${PYTHON_USEDEP}]
!~dev-python/python-cinderclient-1.7.0[${PYTHON_USEDEP}]
!~dev-python/python-cinderclient-1.7.1[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-1.5.0[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-2.3.0[${PYTHON_USEDEP}]
!~dev-python/python-glanceclient-2.4.0[${PYTHON_USEDEP}]
>=dev-python/python-heatclient-1.4.0[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
!~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
>=dev-python/python-magnumclient-2.0.0[${PYTHON_USEDEP}]
>=dev-python/python-manilaclient-1.10.0[${PYTHON_USEDEP}]
>=dev-python/python-mistralclient-2.0.0[${PYTHON_USEDEP}]
>=dev-python/python-monascaclient-1.1.0[${PYTHON_USEDEP}]
>=dev-python/python-neutronclient-5.1.0[${PYTHON_USEDEP}]
>=dev-python/python-novaclient-2.29.0[${PYTHON_USEDEP}]
!~dev-python/python-novaclient-2.33.0[${PYTHON_USEDEP}]
>=dev-python/python-openstackclient-2.1.0[${PYTHON_USEDEP}]
>=dev-python/python-senlinclient-0.3.0[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-2.2.0[${PYTHON_USEDEP}]
>=dev-python/python-troveclient-2.2.0[${PYTHON_USEDEP}]
>=dev-python/python-zaqarclient-1.0.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
!~dev-python/routes-2.0[${PYTHON_USEDEP}]
!~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
!~dev-python/routes-2.3[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
)
mysql? (
>=dev-python/pymysql-0.6.2[${PYTHON_USEDEP}]
!~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
)
postgres? (
>=dev-python/psycopg-2.5.0
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
>=dev-python/yaql-1.1.0[${PYTHON_USEDEP}]"

PATCHES=(
)

pkg_setup() {
enewgroup heat
enewuser heat -1 -1 /var/lib/heat heat
}

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

python_install() {
distutils-r1_python_install
diropts -m0750 -o heat -g heat
keepdir /etc/heat
dodir /etc/heat/environment.d
dodir /etc/heat/templates

for svc in api api-cfn engine; do
newinitd "${FILESDIR}/heat.initd" heat-${svc}
done

insinto /etc/heat
insopts -m0640 -o heat -g heat
newins "${FILESDIR}/newton-heat.conf.sample" "heat.conf.sample"
doins "etc/heat/api-paste.ini"
doins "etc/heat/policy.json"
insinto /etc/heat/templates
doins "etc/heat/templates/"*
insinto /etc/heat/environment.d
doins "etc/heat/environment.d/default.yaml"

dodir /var/log/heat
fowners heat:heat /var/log/heat
}

0 comments on commit 3d07181

Please sign in to comment.