Skip to content

Commit

Permalink
games-emulation/dosbox: remove games eclass and convert to EAPI 6
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/566498
Gentoo-Bug: https://bugs.gentoo.org/587382

Package-Manager: portage-2.2.28
Closes: gentoo#1777

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
austin987 authored and monsieurp committed Jun 28, 2016
1 parent 657cf57 commit 3d239d4
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 6 deletions.
46 changes: 46 additions & 0 deletions games-emulation/dosbox/dosbox-0.74-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa debug hardened opengl"

DEPEND="alsa? ( media-libs/alsa-lib )
debug? ( sys-libs/ncurses:0 )
opengl? ( virtual/glu virtual/opengl )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
RDEPEND=${DEPEND}

PATCHES=(
"${FILESDIR}"/${P}-clang.patch
"${FILESDIR}"/${P}-gcc46.patch
"${FILESDIR}"/${P}-wine-drive-z.patch
"${FILESDIR}"/${P}-wine-filenames.patch
)

src_configure() {
econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \
$(use_enable opengl)
}

src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
}
12 changes: 6 additions & 6 deletions games-emulation/dosbox/dosbox-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6
ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
inherit autotools eutils subversion games
inherit autotools eutils subversion

DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
Expand All @@ -15,8 +15,8 @@ KEYWORDS=""
IUSE="alsa debug hardened opengl"

DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
opengl? ( virtual/glu virtual/opengl )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
Expand All @@ -30,12 +30,13 @@ src_unpack() {
}

src_prepare() {
default
subversion_src_prepare
eautoreconf
}

src_configure() {
egamesconf \
econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
Expand All @@ -47,5 +48,4 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
prepgamesdirs
}

0 comments on commit 3d239d4

Please sign in to comment.