Skip to content

Commit

Permalink
dev-python/msgpack: version bump to 0.4.8
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 22, 2016
1 parent 1b7e927 commit 3d2bea0
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/msgpack/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST msgpack-python-0.4.6.tar.gz 116433 SHA256 bfcc581c9dbbf07cc2f951baf30c3249a57e20dcbd60f7e6ffc43ab3cc614794 SHA512 492246b03035cfb10a99aed59d23a7b10d1fd4cfa044cdec737b4f65fe3f7c30d3c9754389fd5efc2eb41760e4813ac246915ac7a50dc5659e65002a476bb886 WHIRLPOOL 9aa400181557c20d0b1e011424dc4b68de269942b3b7e27e24b113ee4d98f4161355d3479d7ff8c60c0017e0fe28ceb4fca06e67e881982141fa348336eaee85
DIST msgpack-python-0.4.7.tar.gz 126251 SHA256 5e001229a54180a02dcdd59db23c9978351af55b1290c27bc549e381f43acd6b SHA512 10cc51c5f46a908953298071a46a790b9b78a577e37abd546c76f72386c3847885e36523680c86b9a13fb099fc2a17c3c7a0119c750ac5e7081c72df3ebd7a7e WHIRLPOOL 70be4cd3fc76671f311f50966ad5362ef6c94c18270f5dd10b690067fe891166f7929828874f0005ca0da8a2159a31fbd438e6be1d87c1928f845cbb37ac247b
DIST msgpack-python-0.4.8.tar.gz 113641 SHA256 1a2b19df0f03519ec7f19f826afb935b202d8979b0856c6fb3dc28955799f886 SHA512 59e9c43be6b92e6d10f40999e0902c350137e67a83c43bb15b273eca856a6eb39f24b625b02b40188a9365ce3101f03bfa9aa3dfff56c5c3b551533942183481 WHIRLPOOL 461ef108839815a6919accc51be6bfa2a20790dcea3aebffcbb956bc6dc8ea5eac19efb9b36a15850d33693d160d7c67a2d5cc4cb4d6ed2312a731663c1103c6
34 changes: 34 additions & 0 deletions dev-python/msgpack/msgpack-0.4.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )

inherit distutils-r1

MY_PN="${PN}-python"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="MessagePack (de)serializer for Python"
HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack-python/ https://pypi.python.org/pypi/msgpack-python/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/six[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"

S=${WORKDIR}/${MY_P}

python_test() {
py.test test || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 3d2bea0

Please sign in to comment.