forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-plugins/gkrellm-mailwatch: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
1 parent
174151d
commit 3d301bd
Showing
1 changed file
with
9 additions
and
8 deletions.
There are no files selected for viewing
17 changes: 9 additions & 8 deletions
17
x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,31 +1,32 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit gkrellm-plugin toolchain-funcs | ||
|
||
DESCRIPTION="A GKrellM2 plugin that shows the status of additional mail boxes" | ||
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz" | ||
HOMEPAGE="http://gkrellm.luon.net/mailwatch.php" | ||
|
||
SLOT="2" | ||
LICENSE="GPL-2" | ||
SLOT="2" | ||
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86" | ||
IUSE="" | ||
|
||
PLUGIN_SO=mailwatch.so | ||
S="${WORKDIR}/${PN}" | ||
|
||
RDEPEND="app-admin/gkrellm[X]" | ||
RDEPEND="app-admin/gkrellm:2[X]" | ||
DEPEND="${RDEPEND}" | ||
|
||
S=${WORKDIR}/${PN} | ||
PATCHES=( | ||
"${FILESDIR}"/2.4.3-0001-Respect-LDFLAGS.patch | ||
"${FILESDIR}"/2.4.3-0002-Use-gkrellm_gkd_string_width.patch | ||
"${FILESDIR}"/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch | ||
"${FILESDIR}"/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch | ||
) | ||
|
||
src_compile() { | ||
PLUGIN_SO=( mailwatch$(get_modname) ) | ||
|
||
src_configure() { | ||
tc-export CC | ||
default_src_compile | ||
} |