Skip to content

Commit

Permalink
dev-lisp/abcl: add 1.9.1
Browse files Browse the repository at this point in the history
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#29697
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Feb 22, 2023
1 parent 67094a0 commit 3d3ccc5
Show file tree
Hide file tree
Showing 3 changed files with 39 additions and 4 deletions.
1 change: 1 addition & 0 deletions dev-lisp/abcl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST abcl-src-1.9.0.tar.gz 2470791 BLAKE2B e6c79a7f9dc94fe978c81f0752774b54b850c3019eb40a66cb043e6463ae6aa80b8e09d628847017335cf077029f6548be40394adf06a8549609b5bb7cb26dd1 SHA512 d061565a4e89fd11238118fccf72ea212b9bc87c708f89f13e8e9564d984ee405a189b93fd904ecae7b7f6663ca130b5c7ab774f7f9fd31282708c639e3ef9f6
DIST abcl-src-1.9.1.tar.gz 2499007 BLAKE2B 4448a42caa1c283291691eaf5f045504d4e9549b50929ca414094523ea4ce8180f769073b7c8be3358fb3976974c7a86e1b42f850d1ff7f5ab0955731aeabc8b SHA512 52ee6b82d99f8667610afdc4af2065cd868aa6661f6d4d1af1dbae979128529d5b2e0523caf7b3c6a5460ba55636c7aca4b145fabb6b4748b5ac046742fc8960
30 changes: 30 additions & 0 deletions dev-lisp/abcl/abcl-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit java-pkg-2 java-ant-2

DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
HOMEPAGE="https://abcl.org"
SRC_URI="https://abcl.org/releases/${PV}/abcl-src-${PV}.tar.gz"

LICENSE="GPL-2-with-classpath-exception"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND=">=virtual/jdk-1.8:*"
RDEPEND=">=virtual/jre-1.8:*"

S="${WORKDIR}/abcl-src-${PV}"

src_compile() {
eant abcl.compile
eant abcl.jar || die "Can't make ABCL jar archive"
}

src_install() {
java-pkg_dojar dist/abcl.jar dist/abcl-contrib.jar
java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
dodoc README
}
12 changes: 8 additions & 4 deletions dev-lisp/abcl/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -2,15 +2,19 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Common Lisp Project</name>
<email>[email protected]</email>
<name>Gentoo Common Lisp Project</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Java</name>
<email>[email protected]</email>
<name>Java</name>
</maintainer>
<longdescription>
Armed Bear Common Lisp (ABCL) is an implementation of ANSI Common
Lisp that runs in a Java virtual machine.
</longdescription>
<upstream>
<bugs-to>https://abcl.org/trac/report/1</bugs-to>
<remote-id type="github">armedbear/abcl</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 3d3ccc5

Please sign in to comment.