forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/systemrescuecd-x86: Bump to 4.9.0
- Loading branch information
Showing
2 changed files
with
63 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
62 changes: 62 additions & 0 deletions
62
app-admin/systemrescuecd-x86/systemrescuecd-x86-4.9.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant" | ||
HOMEPAGE="http://www.sysresccd.org/" | ||
# Large ISO mirroring explicitly approved by infra in bug #588766 | ||
SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="${PV}" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+isohybrid" | ||
|
||
DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )" | ||
|
||
S=${WORKDIR} | ||
|
||
src_install() { | ||
insinto "/usr/share/${PN%-*}" | ||
doins "${DISTDIR}/${P}.iso" | ||
|
||
if use isohybrid; then | ||
set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso" | ||
echo "${@}" | ||
"${@}" || die "${*} failed" | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso | ||
|
||
# no version newer than ours? we're the newest! | ||
if ! has_version ">${CATEGORY}/${PF}"; then | ||
ln -f -s -v "${P}.iso" "${f}" || die | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso | ||
|
||
# if there is no version newer than ours installed | ||
if ! has_version ">${CATEGORY}/${PF}"; then | ||
# and we are truly and completely uninstalled... | ||
if [[ ! ${REPLACED_BY_VERSION} ]]; then | ||
# then find an older version to set the symlink to | ||
local newest_version=$(best_version "<${CATEGORY}/${PF}") | ||
|
||
if [[ ${newest_version} ]]; then | ||
# update the symlink | ||
ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die | ||
else | ||
# last version removed? clean up the symlink | ||
rm -v "${f}" || die | ||
# and the parent directory | ||
rmdir "${f%/*}" || die | ||
fi | ||
fi | ||
fi | ||
} |