Skip to content

Commit

Permalink
dev-java/xp: Switch to java-pkg-simple.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
monsieurp committed Feb 19, 2016
1 parent 35a9a3d commit 3d43557
Show file tree
Hide file tree
Showing 3 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/xp/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xp-0.5.zip 281324 SHA256 38b35ca80627afafdaa2140f7df339164abb5fceffe8b5783dadc75a05662a1d SHA512 5bf354967a1135209d5c6b3be979a311aa5c909493dea16a0efd31a1838dda12be4005ac7e919620ed68266a333fdc93a07853ec1e0af0e83b329bd40bda74b6 WHIRLPOOL 677a8a52ed3d656a1924cf54c82b4c0688c5736771b4add8e878c0e8ecd049efcc85e7f15b883004e4b7d469bbfc207585860e1c2ccfcaa6c4e2fc81cf05d6a5
DIST xp.zip 281324 SHA256 38b35ca80627afafdaa2140f7df339164abb5fceffe8b5783dadc75a05662a1d SHA512 5bf354967a1135209d5c6b3be979a311aa5c909493dea16a0efd31a1838dda12be4005ac7e919620ed68266a333fdc93a07853ec1e0af0e83b329bd40bda74b6 WHIRLPOOL 677a8a52ed3d656a1924cf54c82b4c0688c5736771b4add8e878c0e8ecd049efcc85e7f15b883004e4b7d469bbfc207585860e1c2ccfcaa6c4e2fc81cf05d6a5
30 changes: 30 additions & 0 deletions dev-java/xp/files/xp-0.5-fix-jdk-1.7-enum.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
diff --git a/com/jclark/xml/sax/Driver.java b/com/jclark/xml/sax/Driver.java
index 2b0d90a..d1efd3e 100644
--- a/com/jclark/xml/sax/Driver.java
+++ b/com/jclark/xml/sax/Driver.java
@@ -160,9 +160,9 @@ public class Driver extends ApplicationImpl

DTD dtd = event.getDTD();

- for (Enumeration enum = dtd.entityNames(DTD.NOTATION);
- enum.hasMoreElements(); ) {
- String name = (String)enum.nextElement();
+ for (Enumeration enumx = dtd.entityNames(DTD.NOTATION);
+ enumx.hasMoreElements(); ) {
+ String name = (String)enumx.nextElement();
Entity entity = dtd.getEntity(DTD.NOTATION, name);
String systemId = entity.getSystemId();
if (systemId != null) {
@@ -173,9 +173,9 @@ public class Driver extends ApplicationImpl
}
dtdHandler.notationDecl(name, entity.getPublicId(), systemId);
}
- for (Enumeration enum = dtd.entityNames(DTD.GENERAL_ENTITY);
- enum.hasMoreElements();) {
- String name = (String)enum.nextElement();
+ for (Enumeration enumx = dtd.entityNames(DTD.GENERAL_ENTITY);
+ enumx.hasMoreElements();) {
+ String name = (String)enumx.nextElement();
Entity entity = dtd.getEntity(DTD.GENERAL_ENTITY, name);
String notationName = entity.getNotationName();
if (notationName != null) {
36 changes: 36 additions & 0 deletions dev-java/xp/xp-0.5-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="XP is an XML 1.0 parser written in Java"
HOMEPAGE="http://www.jclark.com/xml/xp"
SRC_URI="ftp://ftp.jclark.com/pub/xml/${PN}.zip -> ${P}.zip"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
>=virtual/jre-1.6"

DEPEND="
>=virtual/jdk-1.6
app-arch/unzip"

S="${WORKDIR}"

PATCHES=(
"${FILESDIR}/${P}-fix-jdk-1.7-enum.patch"
)

java_prepare() {
java-pkg_clean
epatch "${PATCHES[@]}"
}

0 comments on commit 3d43557

Please sign in to comment.