Skip to content

Commit

Permalink
dev-python/os-vif: 1.9.0 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
prometheanfire committed Feb 24, 2018
1 parent 142373a commit 3d44a1e
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/os-vif/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST os_vif-1.7.0.tar.gz 55976 BLAKE2B 8adb4043f872a76c1120774bd0453f162aa1a3877b8495b1ea32d7f2ca03ae7401885ca190b5f35bb11e7559f08a9a24ee6cee41c6603c7bbd2a987e974106a7 SHA512 815f7ba169ef4c1235ad70f31ec065179fa021701c69304385c1a95a1125db9afc1be9e6ceddfca44fe6ea1866dfdb303f7ded2914a3757b095118e41bfdd19e
DIST os_vif-1.9.0.tar.gz 62461 BLAKE2B cc62aa95b7d131e7c95b0d228ee242fbcb4784818243ac78ba5f9899c76ce8b72c327c8f20e12bf942b96d895551dea85924f0b55c05ed1fd1eabd42c64af4a9 SHA512 a458e3d5dee698d28236b733ae29802c7bf58c1d40743622976c4498a51dec46a7481289d0511fa09231ffc48ce795c56cdeeb6297c185b474174cae59c7207a
40 changes: 40 additions & 0 deletions dev-python/os-vif/os-vif-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
HOMEPAGE="https://github.com/openstack/os-vif"
SRC_URI="mirror://pypi/${PN:0:1}/os_vif/os_vif-${PV}.tar.gz"
S="${WORKDIR}/os_vif-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
>=dev-python/oslo-versionedobjects-1.28.0[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.4.21[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
sed -i '/^pbr/d' requirements.txt || die # pbr should be uncapped in stable/ocata
distutils-r1_python_prepare_all
}

0 comments on commit 3d44a1e

Please sign in to comment.