Skip to content

Commit

Permalink
media-gfx/hydrus: Add 479, drop 473, update 9999
Browse files Browse the repository at this point in the history
Signed-off-by: Ekaterina Vaartis <[email protected]>
Closes: gentoo#24915
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
vaartis authored and juippis committed Apr 14, 2022
1 parent c32e9eb commit 3d46627
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 11 deletions.
2 changes: 1 addition & 1 deletion media-gfx/hydrus/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
DIST hydrus-473.tar.gz 40044270 BLAKE2B 1aecc84aa60318fadffcf3ad3d8358fa4f537ca1ca55ae7ce02aade0e44b266f42ae94c423854874c471e1d8dc0988e232d19f2e5dd4e2d12834055b75814e9a SHA512 372e813deaef82fe02686e4d7fe5f9ab15476a954b53da8b3560a4cf45ad44209b22b727c32510714ff937b0e6116dae403b3a69954e51c5e62b67bea4eda808
DIST hydrus-474.tar.gz 40052948 BLAKE2B 7d323caf6dee2dc8a1dcf792a5c3383b395374d0e5a8fd88489b08a5b4ad295317cd5ae1da95d5435fb44ea8d4bbe4038d821c037c156e11d8b8c8a8582d67be SHA512 b73f5823ff84cf84710dd1fd9f9bfedffb6ce9ffaba8e4b23a7eda4a6a206aeaa8993632858fab9a5934f4c279fc23955cf045cd38af7ccf78b1eb73a0940bdb
DIST hydrus-476.tar.gz 40139397 BLAKE2B 68a3f31a8f250b2c129a9f2562624ec98994e338112eba4f0953aa96dd95abdb97fc60f6a8f28efb5a660f543f596a344a13fe234b3ffb11e6a158b795b0a11c SHA512 5aa59cc2e4d72219d24de10eaeb99ad5b13c0de3af8d9c7e55e3ccea3b897077596401d4d034aac05c018a969f84507618f95ef70d422ac57075bf2d64a692c5
DIST hydrus-478.tar.gz 40150962 BLAKE2B d654d2c12de8c8af6212679ed719892bcb6172d0b2120718e1bca7159ea3ab0f509dd01bf7c6f57f7da4d5e711c7b85cd0ce467ebc5fe0b08214085e3ca13cc5 SHA512 eb92071e0c9a0c3d04ef72336feaa55e47d28c523916484090220f30fa137c7d6b09b1d97e214fd191212a54e5d653eba08cfa1fe3f242a488d22cc331279e9b
DIST hydrus-479.tar.gz 40164261 BLAKE2B 9c9b60c831a84414632a6ddbe51ece66d036aaa1f98cc74f112ee668583fb4ad95572a25e98cfc8d5c9d6886b55110b373534addb27bf9bec5f9bec53b69e8f7 SHA512 7f08fa62c7bcae17a80aca47dc5fcaf1641622590b08fecd3f38749467e7c595d5b49672145df00f480e99e3270e8bb4d98a21053d9eaeed0f0950956e3026ae
Original file line number Diff line number Diff line change
@@ -1,12 +1,15 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite"

inherit python-single-r1 desktop optfeature
DOCS_BUILDER=mkdocs
DOCS_DEPEND="dev-python/mkdocs-material"

inherit python-single-r1 desktop docs optfeature

DESCRIPTION="A booru-like media organizer for the desktop"
HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
Expand Down Expand Up @@ -36,6 +39,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/cbor2[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/cloudscraper[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
Expand Down Expand Up @@ -82,14 +86,13 @@ src_prepare() {
rm -r bin/ || die
# Build files used for CI, not actually needed
rm -r static/build_files || die
# Duplicate license file, not needed
rm license.txt || die
# Python requirements files, not needed
rm requirements_*.txt || die
}

src_compile() {
python_optimize "${S}"
docs_compile
}

src_test() {
Expand All @@ -107,18 +110,23 @@ src_install() {

mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die

local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
local HTML_DOCS=("${S}"/help/)
local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
einstalldocs

# Files only needed for testing
rm test.py hydrus/hydrus_test.py || die
rm -r hydrus/test/ static/testing/ || die

# These files are copied into doc
rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
# The program expects to find documentation here, so add a symlink to doc
dosym "${doc}/html/help" /opt/hydrus/help
# ${DOCS[@]} files are copied into doc
# ${S}/docs/ is the markdown source code for documentation
# .gitignore/.github files aren't needed for the program to work, same with mkdocs files
rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
if use doc; then
# ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
rm -r "${S}/_build" || die
# The program expects to find documentation here, so add a symlink to doc
dosym "${doc}/html" /opt/hydrus/help
fi

insinto /opt/hydrus
doins -r "${S}"/.
Expand Down
1 change: 1 addition & 0 deletions media-gfx/hydrus/hydrus-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -39,6 +39,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/cbor2[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/cloudscraper[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
Expand Down

0 comments on commit 3d46627

Please sign in to comment.