Skip to content

Commit

Permalink
media-sound/flacon: version bump to 4.1.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Closes: gentoo#8211
  • Loading branch information
Coacher authored and monsieurp committed Apr 30, 2018
1 parent 1505294 commit 3d847b4
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/flacon/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST flacon-4.0.0.tar.gz 1294289 BLAKE2B 3afadc3545493558a5eadb7720509410fb448fed1e1fc5511f0ce477ea0e6e876d19e3038d5eb77191b449f730f50e6f1e3e4eacf546b064868863ed918acdee SHA512 64efc3369f11a7345d106a253873bcaf64ff0bbfb045e3554fecdc48a86ee5d150bef06643a5bf481d6e139a45a2bfdee91e730f9aa1354a4772f0d994297b78
DIST flacon-4.1.0.tar.gz 1579869 BLAKE2B 6e0bf31f0eb47bf594d74e0f058f333daa9ee84f9313e75e059f1568386c20f79482926f6f786d332ecfbb72c3991e346a7b98ab8f27a2a4b4ce5c195c23d6bb SHA512 4e786571ba3e157aad2dc27523f8b9de259b44b84c7b054124a610199ef19855832000e4499d18bd6f725f2133bbbbf8d0d75f1cafbdce918605c3b407f6b0ef
97 changes: 97 additions & 0 deletions media-sound/flacon/flacon-4.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# Ignore rudimentary et, uz@Latn, zh_TW translation(s).
PLOCALES="cs cs_CZ de el es es_MX fr gl hu it ja_JP lt ms_MY nb nl nl_BE pl pl_PL pt_BR pt_PT ro_RO ru sr sr@latin tr uk zh_CN"
# Tests require lots of disk space
CHECKREQS_DISK_BUILD=10G

inherit check-reqs cmake-utils eutils gnome2-utils l10n virtualx xdg-utils

DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
HOMEPAGE="https://flacon.github.io/"
SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
app-i18n/uchardet
dev-qt/qtcore:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-qt/linguist-tools:5
dev-qt/qtconcurrent:5
test? (
dev-qt/qttest:5
media-libs/flac
media-sound/mac
media-sound/shntool
media-sound/ttaenc
media-sound/wavpack
)
"

pkg_pretend() {
use test && check-reqs_pkg_pretend
}

pkg_setup() {
use test && check-reqs_pkg_setup
}

src_prepare() {
cmake-utils_src_prepare

# Ignore rudimentary et, uz@Latn, zh_TW translation(s).
rm "translations/${PN}[email protected]" || die
rm "translations/${PN}"_{et,zh_TW}.ts || die

remove_locale() {
rm "translations/${PN}_${1}".{ts,desktop} || die
}

l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
l10n_for_each_disabled_locale_do remove_locale
}

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS="$(usex test)"
)
cmake-utils_src_configure
}

src_test() {
virtx "${BUILD_DIR}/tests/${PN}_test"
}

pkg_postinst() {
elog "${PN} optionally supports formats listed below."
elog "(List will be empty if all extra packages are installed.)"
elog "Please install the required packages and restart ${PN}."
optfeature 'FLAC input and output support' media-libs/flac
optfeature 'WavPack input and output support' media-sound/wavpack
optfeature 'APE input support' media-sound/mac
optfeature 'TTA input support' media-sound/ttaenc
optfeature 'AAC output support' media-libs/faac
optfeature 'MP3 output support' media-sound/lame
optfeature 'Vorbis output support' media-sound/vorbis-tools
optfeature 'MP3 Replay Gain support' media-sound/mp3gain
optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain

gnome2_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 3d847b4

Please sign in to comment.