Skip to content

Commit

Permalink
dev-util/ragel: Fix the include path
Browse files Browse the repository at this point in the history
Address bug #642016.

Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
lu-zero committed Dec 23, 2017
1 parent bfce22f commit 3da0e31
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
41 changes: 41 additions & 0 deletions dev-util/ragel/files/ragel-7.0.0.10-use-pkginclude.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
From 927f380272442ae803fdccfc001b55877f25e7dc Mon Sep 17 00:00:00 2001
From: Adrian Thurston <[email protected]>
Date: Sat, 10 Dec 2016 15:41:30 -0500
Subject: [PATCH] use pkginclude for the headers

---
aapl/Makefile.am | 2 +-
src/Makefile.am | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/aapl/Makefile.am b/aapl/Makefile.am
index fd9f9cb0..80b972f1 100644
--- a/aapl/Makefile.am
+++ b/aapl/Makefile.am
@@ -1,4 +1,4 @@
-include_HEADERS = \
+pkginclude_HEADERS = \
avlbasic.h avlimel.h avlmap.h bstcommon.h compare.h insertsort.h \
sbstset.h avlcommon.h avlimelkey.h avlmel.h bstmap.h dlcommon.h \
mergesort.h sbsttable.h avlibasic.h avliset.h avlmelkey.h bstset.h \
diff --git a/src/Makefile.am b/src/Makefile.am
index 24a19a4b..60554a99 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,11 +16,11 @@ bin_PROGRAMS = ragel

endif

-include_HEADERS = \
+pkginclude_HEADERS = \
action.h fsmgraph.h ragel.h common.h \
gendata.h redfsm.h dot.h

-nodist_include_HEADERS = config.h
+nodist_pkginclude_HEADERS = config.h

ragel_CPPFLAGS = -I$(top_srcdir)/aapl -DBINDIR='"@bindir@"'

--
2.15.1

30 changes: 30 additions & 0 deletions dev-util/ragel/ragel-7.0.0.10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Compiles finite state machines from regular languages into executable code"
HOMEPAGE="https://www.colm.net/open-source/ragel/"
SRC_URI="https://www.colm.net/files/ragel/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
IUSE="vim-syntax"

DEPEND="~dev-util/colm-0.13.0.5"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}-use-pkginclude.patch" )

src_test() {
cd "${S}"/test || die
./runtests.in || die
}

src_install() {
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins ragel.vim
fi
default
}

0 comments on commit 3da0e31

Please sign in to comment.