Skip to content

Commit

Permalink
www-client/opera-developer: Version 57.0.3082.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Sep 18, 2018
1 parent e58ff20 commit 3dc8f82
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera-developer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opera-developer_57.0.3065.0_amd64.rpm 55367540 BLAKE2B 62809c5b986c11517bbac2f941964df07dba2feae16cb974b189fad6fdd29d92c3f198c09ae58aba751c8abb3e3301b87a6c8aca8c1eca0fc6d3f04ca402b489 SHA512 c328381fe9f303e35fae3e3d995c5a186fe885edeb7e86c6de4542133793e7885dbd579e2451a21d95cbdf0941f7a891523486d0b410b9d2b740c3589083ef28
DIST opera-developer_57.0.3072.0_amd64.deb 57858176 BLAKE2B 338f5eea5585c774cd32f2216fd3877ca940c2fbc71a1ae30cf50afaa63e31ae5e00a6a5de298ade5df51de47fa09eb3752b1b0a00326bbf3ebe540d5dd12e52 SHA512 d01f5e898b54aedb73d05fec77926d4c7a3033c3b7bac9931cbd923989ab81aa7a7f152ba80940694e9dc12a3bda1b3b0c3d3c97cf1e93c7cc5cf55fb8c619e7
DIST opera-developer_57.0.3082.0_amd64.deb 58678266 BLAKE2B 0fbed5f242581a907fccd14ad8362172d15d22d8a149386dbfc7f008a326f06d783533735530cc7e1ae56bbb5203f05697075a81266f556613eb7630a3183fc5 SHA512 f697242f9aa29794c82cf70db2f80a170336ccbf5416c76aa08779d4ae29848aa17bd9c429c0009ec1fad8504808f6b82da5270832831632bd09469cd32490ef
113 changes: 113 additions & 0 deletions www-client/opera-developer/opera-developer-57.0.3082.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,113 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"
inherit chromium-2 gnome2-utils multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="https://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
https://download1.operacdn.com/pub/
https://download2.operacdn.com/pub/
https://download3.operacdn.com/pub/
https://download4.operacdn.com/pub/
"
SRC_URI="amd64? ("
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
"
done
SRC_URI+=")"
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}
OPERA_HOME="usr/$(get_libdir)/${PN}"

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
epatch_user

case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

rm usr/bin/${PN} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit 3dc8f82

Please sign in to comment.