Skip to content

Commit

Permalink
dev-cpp/popl: port to EAPI 7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.3, Repoman-3.0.0
Signed-off-by: Jakov Smolic <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
Jakov Smolic authored and thesamesam committed Sep 16, 2020
1 parent 9cc464c commit 3de9f76
Show file tree
Hide file tree
Showing 2 changed files with 12 additions and 12 deletions.
12 changes: 6 additions & 6 deletions dev-cpp/popl/popl-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,21 +1,21 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake

DESCRIPTION="Header-only C++ program options parser library"
HOMEPAGE="https://github.com/badaix/popl"

if [[ ${PV} == *9999 ]] ; then
inherit cmake-utils git-r3
inherit git-r3

EGIT_REPO_URI="https://github.com/badaix/popl.git"
EGIT_BRANCH="develop"
else
inherit cmake-utils

SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
fi

Expand All @@ -25,5 +25,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )

cmake-utils_src_configure
cmake_src_configure
}
12 changes: 6 additions & 6 deletions dev-cpp/popl/popl-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,21 +1,21 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake

DESCRIPTION="Header-only C++ program options parser library"
HOMEPAGE="https://github.com/badaix/popl"

if [[ ${PV} == *9999 ]] ; then
inherit cmake-utils git-r3
inherit git-r3

EGIT_REPO_URI="https://github.com/badaix/popl.git"
EGIT_BRANCH="develop"
else
inherit cmake-utils

SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
fi

Expand All @@ -25,5 +25,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )

cmake-utils_src_configure
cmake_src_configure
}

0 comments on commit 3de9f76

Please sign in to comment.