Skip to content

Commit

Permalink
net-misc/youtube-dl: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Dec 18, 2017
1 parent 941ba5d commit 3e48af9
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 BLAKE2B 2aff8710a296140a4329b0f8e7f575
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
DIST youtube-dl-2017.11.26.tar.gz 2839867 BLAKE2B c4f1b9739283fb4016ff0892bdcb0db86f1ddc88842553d76159fe4312e70e7145085f3b6a1bfc157d7f5811f28eb1ab79661db701a3366be12be2357b464f19 SHA512 ecf1eb88b37e271505a50709a468afcc6048f00bc6531e8df1eb064dcea62ad6fa2a5a9016d1d106e56b9d3b9904325e133491ca124e06ec64e6f4a5902a2368
DIST youtube-dl-2017.12.02.tar.gz 2845664 BLAKE2B b7b3479b32d9a4d9ee73d1a06337789e080c464ff63eb4c604eb976a5e9f4822a456207de99f2c77b012c722d1cadfe52ac08f2c4a78c5defab797b3f813bc87 SHA512 46a103f8659166ebb79f5055cc435008fcd98b00cff4bfe0680cb4eebc34598edc6a05e73bf6a22647edce007afbcfd61bef6064adc8c2e0eab3fb2b9ee748a3
DIST youtube-dl-2017.12.14.tar.gz 2850664 BLAKE2B 29a3f4fcefaa970e9bc291ab47c5faa28252086aa284e9461f6c061d0e230680fa09ab654520c0cb4080279dba2c96b06412b6e5f4129fe44bcf972967eb57f6 SHA512 b23ffe0e30ba32c80de627305409d5aab73c6337ac6b253fa1c116a4aadf7ddd6853cd612941d9ae0d9ca3bfa5fc982e43cf2cdec3ebb90d2919f3faa47b58c5
116 changes: 116 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2017.12.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
inherit bash-completion-r1 distutils-r1 readme.gentoo-r1

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="+offensive test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

python_prepare_all() {
if ! use offensive; then
sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink camwithher chaturbate eporner
eroprofile extremetube foxgay goshgay hellporno hentaistigma
hornbunny keezmovies lovehomeporn mofosex motherless myvidster
porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
youporn
)
# these have multi-line import statements
local mxxx=(
drtuber fourtube pornhub redtube tnaflix xhamster
)
# do single line imports
sed -i \
-e $( printf '/%s/d;' ${xxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

# do multiple line imports
sed -i \
-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

sed -i \
-e $( printf '/%s/d;' ${mxxx[@]} ) \
youtube_dl/extractor/generic.py \
|| die

rm \
$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
test/test_age_restriction.py \
|| die
fi

eapply_user

distutils-r1_python_prepare_all
}

src_compile() {
distutils-r1_src_compile
}

python_test() {
emake test
}

python_install_all() {
dodoc README.txt
doman ${PN}.1

newbashcomp ${PN}.bash-completion ${PN}

insinto /usr/share/zsh/site-functions
newins youtube-dl.zsh _youtube-dl

insinto /usr/share/fish/completions
doins youtube-dl.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
rm -r "${ED}"/usr/share/doc/youtube_dl || die
}

pkg_postinst() {
elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
elog
elog "${PN} works fine on its own on most sites. However, if you want"
elog "to convert video/audio, you'll need avconf (media-video/libav) or"
elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
elog "videos can be retrieved in a higher quality format without sound."
elog "${PN} will detect whether avconv/ffmpeg is present and"
elog "automatically pick the best option."

elog
elog "Videos or video formats streamed via RTMP protocol can only be"
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
elog "Downloading MMS and RTSP videos requires either mplayer"
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
}

0 comments on commit 3e48af9

Please sign in to comment.