Skip to content

Commit

Permalink
sys-cluster/ceph: Version bump to 10.2.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
chutz committed Oct 6, 2017
1 parent 3e669f1 commit 3e4ea9c
Show file tree
Hide file tree
Showing 2 changed files with 306 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/ceph/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ceph-10.2.10.tar.gz 14573701 SHA256 41210ac8cb71d9c9d6504b57adce496d3272ee8f79089537d262898747d68e75 SHA512 883d1b8340aaefc7a1eee4bbfb5b1d1cc15bffed8f35fb1e8fb86b1208a4d0d16753eb6c688ea0e661c4877d3d148b2b6c2b41620c4e8a61e47c69f46f98e537 WHIRLPOOL 4a2c7b9c7ff2f7f7bf5b36314f2da5630cf948b1558e4b6d33669ffd76836d7fdb6104f3bddcf7209ead2a31209fcc59fe86020763303be10db52729d5e5b648
DIST ceph-10.2.3.tar.gz 11596171 SHA256 dca933aa14db67b404d836ef510bd418091978edc2f0c74dfc530ba0aa5e8994 SHA512 9de1e6851fc343d2c52c72cec3f7887d998d5b588f1251ee3a1fda14427badfa10408e6691fb03a374a10f4ec9844868423fee70fbbe2c0d962af98481412f19 WHIRLPOOL 981ebca66113a07a5cc6e5934272a72b29a2c19e03398f7b622c11df6ea0a05339558dfc2f11504403cbbd0efe0b090ad59f4b86206b46db57587744091aa26a
DIST ceph-10.2.7.tar.gz 14518491 SHA256 2cdfeaa9a08e94c2d35f540b450bbf64b2a694bd537679834185e98fc59d8ba2 SHA512 7e0686e9efa4ddd9d548f4145b448f8232f1ca29b08428daa5cd60a74ce26f1176a1f2ebbf2ac1761d9e6c1d364a5ffa194d2b3a18a8111f59b7c27f7a1d7734 WHIRLPOOL b6b6902230401b5f4c6f27801f315678bdc7b99aab4e50b54d941fc3a425b4f0fa9390484f2e12d6b4f962253fb8772fb706dad35d490b4542b06db166fab59b
DIST ceph-10.2.9.tar.gz 14550219 SHA256 3d93f4fc4a66b1d9f9ce43f65868dc18287cea32fbb2c7421faca6aed2b52a80 SHA512 1d59146614aa87ca551b05b795a684071a3cfb4ce6013e978ba650403c6732b2aa13f3c3cc191e6a1ea34b4631c82e97700593c24e200c41ec2f2b43b3ef5547 WHIRLPOOL 42215d33c4f617087e1b0ef81cd41b42330c3605acf625b0668d44eba9e982239683b466a1cc1a6f926fc1d439dfd6be4ce220f783da7d2214d36a2a6cc9181f
Expand Down
305 changes: 305 additions & 0 deletions sys-cluster/ceph/ceph-10.2.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,305 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )

inherit check-reqs autotools eutils python-r1 udev user \
readme.gentoo-r1 systemd versionator flag-o-matic toolchain-funcs

if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="https://ceph.com/"

LICENSE="LGPL-2.1"
SLOT="0"

IUSE="babeltrace cephfs cryptopp debug fuse gtk jemalloc ldap +libaio"
IUSE+=" libatomic lttng +nss +radosgw static-libs +tcmalloc test xfs zfs"

# unbundling code commented out pending bugs 584056 and 584058
#>=dev-libs/jerasure-2.0.0-r1
#>=dev-libs/gf-complete-2.0.0
COMMON_DEPEND="
app-arch/snappy:=
sys-libs/zlib:=
app-arch/lz4:=
app-arch/bzip2:=
app-arch/zstd:=
dev-libs/boost:=[threads]
dev-libs/libaio:=
dev-libs/leveldb:=[snappy]
nss? ( dev-libs/nss:= )
libatomic? ( dev-libs/libatomic_ops:= )
cryptopp? ( dev-libs/crypto++:= )
sys-apps/keyutils
sys-apps/util-linux
dev-libs/libxml2:=
radosgw? ( dev-libs/fcgi:= )
ldap? ( net-nds/openldap:= )
babeltrace? ( dev-util/babeltrace )
fuse? ( sys-fs/fuse:0= )
xfs? ( sys-fs/xfsprogs:= )
zfs? ( sys-fs/zfs:= )
gtk? (
x11-libs/gtk+:2=
dev-cpp/gtkmm:2.4
gnome-base/librsvg:=
)
radosgw? (
dev-libs/fcgi:=
dev-libs/expat:=
net-misc/curl:=
)
jemalloc? ( dev-libs/jemalloc:= )
!jemalloc? ( =dev-util/google-perftools-2.4*:= )
lttng? ( dev-util/lttng-ust:= )
${PYTHON_DEPS}
"
DEPEND="${COMMON_DEPEND}
dev-python/cython[${PYTHON_USEDEP}]
app-arch/cpio
virtual/pkgconfig
dev-python/sphinx
test? (
sys-fs/btrfs-progs
sys-apps/grep[pcre]
dev-python/tox[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
RDEPEND="${COMMON_DEPEND}
sys-apps/hdparm
sys-block/parted
sys-fs/cryptsetup
sys-apps/gptfdisk
!<sys-apps/openrc-0.26.3
dev-python/flask[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
"
REQUIRED_USE="
$(python_gen_useflags 'python2*')
${PYTHON_REQUIRED_USE}
^^ ( nss cryptopp )
?? ( jemalloc tcmalloc )
"

# work around bug in ceph compilation (rgw/ceph_dencoder-rgw_dencoder.o... undefined reference to `vtable for RGWZoneGroup')
REQUIRED_USE+=" radosgw"

#RESTRICT="test? ( userpriv )"

# distribution tarball does not include everything needed for tests
RESTRICT+=" test"

STRIP_MASK="/usr/lib*/rados-classes/*"

UNBUNDLE_LIBS=(
src/erasure-code/jerasure/jerasure
src/erasure-code/jerasure/gf-complete
)

PATCHES=(
"${FILESDIR}/ceph-10.2.0-dont-use-virtualenvs.patch"
#"${FILESDIR}/ceph-10.2.1-unbundle-jerasure.patch"
"${FILESDIR}/${PN}-10.2.1-libzfs.patch"
"${FILESDIR}/${PN}-10.2.3-build-without-openldap.patch"
"${FILESDIR}/${PN}-10.2.5-Make-RBD-Python-bindings-compatible-with-Python-3.patch"
"${FILESDIR}/${PN}-10.2.5-Make-CephFS-bindings-and-tests-compatible-with-Python-3.patch"
"${FILESDIR}/${PN}-10.2.7-fix-compilation-with-zstd.patch"
"${FILESDIR}/${PN}-10.2.9-cflags.patch"
"${FILESDIR}/${PN}-10.2.9-dont-run-lsb_release.patch"
)

check-reqs_export_vars() {
if use debug; then
CHECKREQS_DISK_BUILD="23G"
CHECKREQS_DISK_USR="7G"
elif use amd64; then
CHECKREQS_DISK_BUILD="12G"
CHECKREQS_DISK_USR="450M"
else
CHECKREQS_DISK_BUILD="1400M"
CHECKREQS_DISK_USR="450M"
fi

export CHECKREQS_DISK_BUILD CHECKREQS_DISK_USR
}

user_setup() {
enewgroup ceph ${CEPH_GID}
enewuser ceph "${CEPH_UID:--1}" -1 /var/lib/ceph ceph
}

emake_python_bindings() {
local action="${1}" params binding module
shift
params=("${@}")

__emake_python_bindings_do_impl() {
ceph_run_econf "${EPYTHON}"
emake "${params[@]}" PYTHON="${EPYTHON}" "${binding}-pybind-${action}"

# these don't work and aren't needed on python3
if [[ ${EBUILD_PHASE} == install ]]; then
for module in "${S}"/src/pybind/*.py; do
module_basename="$(basename "${module}")"
if [[ ${module_basename} == ceph_volume_client.py ]] && ! use cephfs; then
continue
elif [[ ! -e "${ED}/$(python_get_sitedir)/${module_basename}" ]]; then
python_domodule ${module}
fi
done
fi
}

pushd "${S}/src"
for binding in rados rbd $(use cephfs && echo cephfs); do
python_foreach_impl __emake_python_bindings_do_impl
done
popd

unset __emake_python_bindings_do_impl
}

pkg_pretend() {
check-reqs_export_vars
check-reqs_pkg_pretend
}

pkg_setup() {
python_setup
check-reqs_export_vars
check-reqs_pkg_setup
user_setup
}

src_prepare() {
default

# remove tests that need root access
rm src/test/cli/ceph-authtool/cap*.t

#rm -rf "${UNBUNDLE_LIBS[@]}"

append-flags -fPIC

if tc-is-gcc && [[ $(gcc-fullversion) == "7.2.0" ]] && is-flag "-g*"; then
ewarn "Filtering out -g* flags since gcc-7.2 tends to ICE with them and ceph"
filter-flags "-g*"
fi
eautoreconf
}

src_configure() {
ECONFARGS=(
--without-hadoop
--includedir=/usr/include
$(use_with cephfs)
$(use_with debug)
$(use_with fuse)
$(use_with libaio)
$(use_with libatomic libatomic-ops)
$(use_with nss)
$(use_with cryptopp)
$(use_with radosgw)
$(use_with gtk gtk2)
$(use_enable static-libs static)
$(use_with jemalloc)
$(use_with xfs libxfs)
$(use_with zfs libzfs)
$(use_with lttng )
$(use_with babeltrace)
$(use_with ldap openldap)
$(use jemalloc || usex tcmalloc " --with-tcmalloc" " --with-tcmalloc-minimal")
--with-mon
--with-eventfd
--with-cython
--without-kinetic
--without-librocksdb
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
)

# we can only use python2.7 for building at the moment
ceph_run_econf "python2*"
}

ceph_run_econf() {
[[ -z ${ECONFARGS} ]] && die "called ${FUNCNAME[0]} with ECONFARGS unset"
[[ -z ${1} ]] && die "called ${FUNCNAME[0]} without passing python implementation"

pushd "${S}" >/dev/null || die
#
# This generates a QA warning about running econf in src_compile
# and src_install. Unfortunately the only other way to do this would
# involve building all of for each python implementation times, which
# wastes a _lot_ of CPU time and disk space. This hack will no longer
# be needed with >=ceph-11.2.
#
python_setup "${1}"
econf "${ECONFARGS[@]}"

popd >/dev/null || die
}

src_compile() {
emake
emake_python_bindings all

use test && emake check-local
}

src_test() {
make check || die "make check failed"
}

src_install() {
default
emake_python_bindings install-exec "DESTDIR=\"${D}\""

prune_libtool_files --all

exeinto /usr/$(get_libdir)/ceph
newexe src/init-ceph ceph_init.sh

insinto /etc/logrotate.d/
newins "${FILESDIR}"/ceph.logrotate ${PN}

keepdir /var/lib/${PN}{,/tmp} /var/log/${PN}/stat

fowners -R ceph:ceph /var/lib/ceph /var/log/ceph

newinitd "${FILESDIR}/rbdmap.initd" rbdmap
newinitd "${FILESDIR}/${PN}.initd-r5" ${PN}
newconfd "${FILESDIR}/${PN}.confd-r3" ${PN}

insinto /etc/sysctl.d
newins "${FILESDIR}"/sysctld 90-${PN}.conf

use tcmalloc && newenvd "${FILESDIR}"/envd-tcmalloc 99${PN}-tcmalloc

systemd_install_serviced "${FILESDIR}/ceph-mds_at.service.conf" "[email protected]"
systemd_install_serviced "${FILESDIR}/ceph-osd_at.service.conf" "[email protected]"

udev_dorules udev/*.rules

readme.gentoo_create_doc

python_setup 'python2*'
python_fix_shebang "${ED}"/usr/{,s}bin/

# python_fix_shebang apparently is not idempotent
sed -i -r 's:(/usr/lib/python-exec/python[0-9]\.[0-9]/python)[0-9]\.[0-9]:\1:' \
"${ED}"/usr/{sbin/ceph-disk,bin/ceph-detect-init} || die "sed failed"
}

pkg_postinst() {
readme.gentoo_print_elog
}

0 comments on commit 3e4ea9c

Please sign in to comment.