Skip to content

Commit

Permalink
app-portage/portage-utils: add live ebuild
Browse files Browse the repository at this point in the history
Signed-off-by: Fabian Groffen <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
grobian committed Apr 14, 2019
1 parent 798aac5 commit 3e6b19c
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions app-portage/portage-utils/portage-utils-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit toolchain-funcs

DESCRIPTION="Small and fast Portage helper tools written in C"
HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"

LICENSE="GPL-2"
SLOT="0"
IUSE="nls static"

if [[ ${PV} == *9999 ]]; then
inherit git-r3 autotools
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
else
SRC_URI="mirror://gentoo/${P}.tar.xz
https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

RDEPEND="dev-libs/iniparser:0"
DEPEND="${RDEPEND}
app-arch/xz-utils
static? ( dev-libs/iniparser:0[static-libs] )"

src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}

src_configure() {
econf --with-eprefix="${EPREFIX}"
}

0 comments on commit 3e6b19c

Please sign in to comment.