Skip to content

Commit

Permalink
www-servers/monkeyd: version bump to 1.6.7
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
blueness committed Jan 1, 2016
1 parent 1f9aca2 commit 3eb1032
Show file tree
Hide file tree
Showing 2 changed files with 142 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-servers/monkeyd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST monkey-1.5.6.tar.gz 902636 SHA256 7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22 SHA512 4c7c627cb047252252b22da5fba179a21fb5b8dc6280b96307af52757ad049d24b0daaaea51dca4f0429af5e6499c239f6b62a03654cc9e7ad98ae8f5149b64c WHIRLPOOL aba1a928023fc67224f254182eb9707c6594c7092d9ff98ecfa297c91d5c61f79235e7467192b5d46ac114ae67a3cee98e06704721348a40ee825755ab39d9a1
DIST monkey-1.6.6.tar.gz 2035885 SHA256 4ad8258d6cb6fb8b9d98891a7c84a559ab7ab96f7dde0ecdfc23a1a8d594ce11 SHA512 c56edcd2bb18fbe4e4f364853e4796be1211cca7829899cde94500d514ded7ba8cca44c6e5f964b8864d0348caf1a570ac558c287f708c081a40aeecef8ee2cf WHIRLPOOL 60b95e0c81b9ce3faf2a87acf9496a8510d5d6d66501850c2d45cab39505b58f9f22ec9936002ff06cd4b13d6ac787b144409f64625fc56042fdfef4bfee79a4
DIST monkey-1.6.7.tar.gz 2038458 SHA256 32bf4126d1947c426eb2aa269f4bfa08fe5e42b4966468f2fea8e9a3cdfc8ea1 SHA512 7da091f7252c7188e7a30c56c704984d3806b001bb74c15b6f742fc527304cb8821b6da5da2a7275f15f5cd29c3d412ad0534075867893b4aea7a6f8a309df90 WHIRLPOOL fdc451925b241f1ef3b8b4e6e6dd6c2869b3408d1ad41498107f12cd04e845a730501f5c8c070c30643ae9fa4384395034e7ccd2b3da30e61730def4e9a1b91a
141 changes: 141 additions & 0 deletions www-servers/monkeyd/monkeyd-1.6.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,141 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils flag-o-matic toolchain-funcs multilib

DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
MY_P="${PN/d}-${PV}"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/monkey/monkey.git"
inherit git-2
KEYWORDS=""
else
SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"

# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"

PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"

# uclibc is often compiled without backtrace info so we should
# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
monkeyd_plugins_tls? ( !static-plugins )
elibc_uclibc? ( !debug )
cgi? ( php )"

#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
DEPEND="
dev-util/cmake
monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
RDEPEND="
php? ( dev-lang/php )
cgi? ( dev-lang/php[cgi] )"

S="${WORKDIR}/${MY_P}"

WEBROOT="/var/www/localhost"

pkg_setup() {
if use debug; then
ewarn
ewarn "\033[1;33m**************************************************\033[00m"
ewarn "Do not use debug in production!"
ewarn "\033[1;33m**************************************************\033[00m"
ewarn
fi
}

src_prepare() {
# Unconditionally get rid of the bundled jemalloc
rm -rf "${S}"/deps
epatch "${FILESDIR}"/${PN}-1.6.3-system-mbedtls.patch
}

src_configure() {
local myconf=""

use elibc_uclibc && myconf+=" --uclib-mode"
use elibc_musl && myconf+=" --musl-mode"

#use jemalloc || myconf+=" --malloc-libc"
myconf+=" --malloc-libc"

if use debug; then
myconf+=" --debug --trace"
else
myconf+=" --no-backtrace"
fi

local enable_plugins=""
local disable_plugins=""
# We use 'cgi' and 'fastcgi' because they are global flags
# instead of the corresponding monkeyd_plugins_*
use cgi && enable_plugins+="cgi," || disable_plugins+="cgi,"
use fastcgi && enable_plugins+="fastcgi," || disable_plugins+="fastcgi,"
# For the rest, we scan the monkeyd_plugins_* and parse out the plugin name.
local p
for p in ${PLUGINS}; do
pp=${p/+/}
cp=${pp/monkeyd_plugins_/}
use $pp && enable_plugins+="${cp}," || disable_plugins+="${cp},"
done
myconf+=" --enable-plugins=${enable_plugins%,} --disable-plugins=${disable_plugins%,}"
if use static-plugins; then
myconf+=" --static-plugins=${enable_plugins%,}"
fi

# For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
# but shouldn't because it is POSIX. This needs to be fixed
# in uClibc. Also, we really should us append-cppflags but
# monkey's build system doesn't respect CPPFLAGS. This needs
# to be fixed in monkey.
use elibc_uclibc && append-cflags -D_GNU_SOURCE

# Non-autotools configure
./configure \
--pthread-tls \
--prefix=/usr \
--sbindir=/usr/sbin \
--webroot=${WEBROOT}/htdocs \
--logdir=/var/log/${PN} \
--mandir=/usr/share/man \
--libdir=/usr/$(get_libdir) \
--pidfile=/run/monkey.pid \
--sysconfdir=/etc/${PN} \
${myconf} \
|| die
}

src_compile() {
emake VERBOSE=1
}

src_install() {
default

newinitd "${FILESDIR}"/monkeyd.initd-r1 monkeyd
newconfd "${FILESDIR}"/monkeyd.confd monkeyd

# Move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
mv "${D}"${WEBROOT}/htdocs \
"${D}"/usr/share/doc/"${PF}"/htdocs.dist || die

keepdir \
/var/log/monkeyd \
${WEBROOT}/htdocs

# This needs to be created at runtime
rm -rf "${D}"/run
}

0 comments on commit 3eb1032

Please sign in to comment.