Skip to content

Commit

Permalink
dev-ruby/hiera-eyaml: add 3.2.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Nov 25, 2021
1 parent 4bae45c commit 3edb367
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/hiera-eyaml/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hiera-eyaml-3.1.1.tar.gz 54848 BLAKE2B 8daa4925bf1fb945ddb5ce7a485c3bf2bfca8747eb0cf00530eb91307d18d3f5c73699a30631b80e7825baac3a8b0c1695bd0313906bc8c7aba9c3c00d69b9cc SHA512 3bc93ca31af96383401f28644490f5540a70cf719e47d340794daf6c8bcc7fe9800d1d1e6ba99aba344831966f8d15f1a1fd9d1522696457f0bdec79dd45a108
DIST hiera-eyaml-3.2.2.tar.gz 59174 BLAKE2B 2e31d1d0807096757f338a3f112a2f853f9dc61d14f92720a06e8835ef5b2228cea1ef2db1d5d7a2758422158acca14e882e1fa88a3189fcc254573e15e32185 SHA512 ac7800d35cba9b11e1fcfd831419caa1fb32fc1747499f780a40005cf57a87be4562f52251b8f5482156ad98892d41fe5060e48f74a75a0d1657dd5c04b8ee92
49 changes: 49 additions & 0 deletions dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26 ruby27"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md PLUGINS.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="Encrypted YAML backend for hiera"
HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="3"
KEYWORDS="~amd64 ~x86"
IUSE="test"

ruby_add_rdepend ">=dev-ruby/highline-1.6.19:*"
ruby_add_rdepend "dev-ruby/optimist"
ruby_add_rdepend "!!dev-ruby/hiera-eyaml:0" # both install the /usr/bin/eyaml binary

ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 <app-admin/puppet-6 dev-ruby/hiera-eyaml-plaintext )"

all_ruby_prepare() {
# Fix highline dependency to be compatible with more versions.
sed -i -e '/highline/ s/~>/>=/' \
-e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die

sed -i -e 's:/tmp:'${T}':' \
features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-envvar/environments/local/modules/test/manifests/run.pp \
features/puppet.feature
}

each_ruby_prepare() {
# Run tests with the correct ruby interpreter
sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die

}

each_ruby_test() {
${RUBY} -S cucumber --format progress features || die
}

0 comments on commit 3edb367

Please sign in to comment.