Skip to content

Commit

Permalink
dev-embedded/u-boot-tools: add 2022.04
Browse files Browse the repository at this point in the history
Signed-off-by: Jakov Smolić <[email protected]>
  • Loading branch information
jsmolic committed Apr 27, 2022
1 parent d71a7bd commit 3ef3947
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/u-boot-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST u-boot-2022.01.tar.bz2 17449627 BLAKE2B 574f9d248a8c19aa20b1b16cb55bb201d6c1ab2162da3f8789d39286a4f4a5a76b772d4a49c17e5572ff69f489d1d6fdc02d6e8f67a8bf6c50159b1a41e7c81d SHA512 d83c62bd8f0f51664d2aca329a3ce1379cfd1dfff439dccd6cfc2cb33cfef89a2b01855c97716f591b5550bfdf99e2f3aef7efa33f2e7834c820648f9eef3825
DIST u-boot-2022.04.tar.bz2 17772787 BLAKE2B 5d2035130c0631f8f1b7f7963bedf71578a66994e3950eb103a404a08e85686cd971ba51e8172093ccb75d975101024bf2a94d4064763ad57ad8950c11092319 SHA512 113056e542db049eea3b1d1ccbbe52c79539a2f9bb6129d284ec9200dcffec7bd5969821913a9899631575b80991c84ad01bc845b4bba614e42e54466d9f0d64
79 changes: 79 additions & 0 deletions dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

MY_P="u-boot-${PV/_/-}"
DESCRIPTION="utilities for working with Das U-Boot"
HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
SRC_URI="https://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
IUSE="envtools"

RDEPEND="dev-libs/openssl:="
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
"

src_prepare() {
default
sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
scripts/kconfig/{g,m,n,q}conf-cfg.sh \
scripts/kconfig/Makefile \
tools/Makefile || die
}

src_configure() {
tc-export AR BUILD_CC CC PKG_CONFIG
}

src_compile() {
# Unset a few KBUILD variables. Bug #540476
unset KBUILD_OUTPUT KBUILD_SRC

local myemakeargs=(
V=1
AR="${AR}"
CC="${CC}"
HOSTCC="${BUILD_CC}"
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)'
HOSTLDFLAGS="${LDFLAGS}"
)

emake "${myemakeargs[@]}" tools-only_defconfig

emake "${myemakeargs[@]}" \
NO_SDL=1 \
HOSTSTRIP=: \
STRIP=: \
CONFIG_ENV_OVERWRITE=y \
$(usex envtools envtools tools-all)
}

src_test() { :; }

src_install() {
cd tools || die

if ! use envtools; then
dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
fi

dobin env/fw_printenv

dosym fw_printenv /usr/bin/fw_setenv

insinto /etc
doins env/fw_env.config

doman ../doc/mkimage.1
}

0 comments on commit 3ef3947

Please sign in to comment.