Skip to content

Commit

Permalink
app-crypt/mhash: style changes
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Mar 31, 2021
1 parent b14723d commit 3ef9576
Show file tree
Hide file tree
Showing 9 changed files with 35 additions and 44 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -7,9 +7,8 @@ Gentoo-Bug-URL: http://bugs.gentoo.org/show_bug.cgi?id=221093
Patch-URL: http://bugs.gentoo.org/attachment.cgi?id=152625&action=view
Signed-off-by: Peter Alfredson <[email protected]>

diff -NrU5 mhash-0.9.9.orig/configure.in mhash-0.9.9/configure.in
--- mhash-0.9.9.orig/configure.in 2008-05-09 16:17:52.000000000 +0200
+++ mhash-0.9.9/configure.in 2008-05-09 16:18:20.000000000 +0200
--- a/configure.in
+++ b/configure.in
@@ -4,10 +4,11 @@
AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([lib/mhash.c])
Expand All @@ -22,9 +21,8 @@ diff -NrU5 mhash-0.9.9.orig/configure.in mhash-0.9.9/configure.in

dnl Check system.

diff -NrU5 mhash-0.9.9.orig/include/mutils/config.h.in mhash-0.9.9/include/mutils/config.h.in
--- mhash-0.9.9.orig/include/mutils/config.h.in 1970-01-01 01:00:00.000000000 +0100
+++ mhash-0.9.9/include/mutils/config.h.in 2008-05-09 16:18:20.000000000 +0200
--- a/include/mutils/config.h.in
+++ b/include/mutils/config.h.in
@@ -0,0 +1,22 @@
+/* Name of package */
+#undef PACKAGE
Expand All @@ -48,9 +46,8 @@ diff -NrU5 mhash-0.9.9.orig/include/mutils/config.h.in mhash-0.9.9/include/mutil
+#undef VERSION
+
+
diff -NrU5 mhash-0.9.9.orig/include/mutils/mhash_config.h.in mhash-0.9.9/include/mutils/mhash_config.h.in
--- mhash-0.9.9.orig/include/mutils/mhash_config.h.in 2008-05-09 16:17:52.000000000 +0200
+++ mhash-0.9.9/include/mutils/mhash_config.h.in 2008-05-09 16:19:17.000000000 +0200
--- a/include/mutils/mhash_config.h.in
+++ b/include/mutils/mhash_config.h.in
@@ -179,28 +179,10 @@
#undef MHASH_VERSION

Expand Down
4 changes: 2 additions & 2 deletions app-crypt/mhash/files/mhash-0.9.9-fix-mem-leak.patch
Original file line number Diff line number Diff line change
Expand Up @@ -14,8 +14,8 @@ Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=255006
Patch-URL: http://bugs.gentoo.org/attachment.cgi?id=178560
Signed-off-by: Thomas Harning <[email protected]>

--- mhash-0.9.9/lib/mhash.c 2007-02-21 01:18:46.000000000 -0500
+++ mhash-0.9.9-new/lib/mhash.c 2009-01-15 01:57:53.000000000 -0500
--- a/lib/mhash.c
+++ b/lib/mhash.c
@@ -719,6 +719,8 @@
mutils_memcpy( &ret->state_size, &mem[pos], sizeof(ret->state_size));
pos += sizeof( ret->state_size);
Expand Down
4 changes: 2 additions & 2 deletions app-crypt/mhash/files/mhash-0.9.9-fix-snefru-segfault.patch
Original file line number Diff line number Diff line change
Expand Up @@ -14,8 +14,8 @@ Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=255131
Patch-URL: http://bugs.gentoo.org/attachment.cgi?id=178666&action=view
Signed-off-by: Thomas Harning <[email protected]>

--- mhash-0.9.9/lib/snefru.c 2009-01-16 00:16:04.000000000 -0500
+++ mhash-0.9.9-new/lib/snefru.c 2009-01-16 00:16:21.000000000 -0500
--- a/lib/snefru.c
+++ b/lib/snefru.c
@@ -859,6 +859,8 @@
{
mutils_word32 i;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,8 +14,8 @@ Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=255131
Patch-URL: http://bugs.gentoo.org/attachment.cgi?id=178667&action=view
Signed-off-by: Thomas Harning <[email protected]>

--- mhash-0.9.9/lib/whirlpool.c 2006-01-08 03:14:47.000000000 -0500
+++ mhash-0.9.9-new/lib/whirlpool.c 2009-01-16 00:17:34.000000000 -0500
--- a/lib/whirlpool.c
+++ b/lib/whirlpool.c
@@ -970,6 +970,8 @@
mutils_word8 * digest)
{
Expand Down
5 changes: 2 additions & 3 deletions app-crypt/mhash/files/mhash-0.9.9.9-align.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -up mhash-0.9.9.9/lib/stdfns.c.BAD mhash-0.9.9.9/lib/stdfns.c
--- mhash-0.9.9.9/lib/stdfns.c.BAD 2009-07-02 16:38:43.217029623 -0400
+++ mhash-0.9.9.9/lib/stdfns.c 2009-07-02 16:41:58.647120391 -0400
--- a/lib/stdfns.c
+++ b/lib/stdfns.c
@@ -152,6 +152,18 @@ mutils_bzero(void *s, __const mutils_wor
}
}
Expand Down
5 changes: 2 additions & 3 deletions app-crypt/mhash/files/mhash-0.9.9.9-alignment.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -up mhash-0.9.9.9/lib/stdfns.c.BAD mhash-0.9.9.9/lib/stdfns.c
--- mhash-0.9.9.9/lib/stdfns.c.BAD 2009-07-21 12:05:40.139461097 -0400
+++ mhash-0.9.9.9/lib/stdfns.c 2009-07-21 12:06:52.151190927 -0400
--- a/lib/stdfns.c
+++ b/lib/stdfns.c
@@ -378,6 +378,12 @@ mutils_memmove(void *dest, __const void
bigptr1 = (mutils_word32 *) dest;
bigptr2 = (mutils_word32 *) src;
Expand Down
5 changes: 2 additions & 3 deletions app-crypt/mhash/files/mhash-0.9.9.9-force64bit-tiger.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -up mhash-0.9.9.9/lib/tiger.c.BAD mhash-0.9.9.9/lib/tiger.c
--- mhash-0.9.9.9/lib/tiger.c.BAD 2009-07-02 16:42:47.683029940 -0400
+++ mhash-0.9.9.9/lib/tiger.c 2009-07-02 16:43:46.085049317 -0400
--- a/lib/tiger.c
+++ b/lib/tiger.c
@@ -252,7 +252,9 @@ void tiger_update(struct tiger_ctx *ctx,
void tiger_final(struct tiger_ctx *ctx)
{
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -ru mhash-0.9.9.9.orig/src/keygen_test.c mhash-0.9.9.9/src/keygen_test.c
--- mhash-0.9.9.9.orig/src/keygen_test.c 2007-02-21 07:39:08.000000000 +0100
+++ mhash-0.9.9.9/src/keygen_test.c 2009-12-04 01:29:16.000000000 +0100
--- a/src/keygen_test.c
+++ b/src/keygen_test.c
@@ -121,8 +121,6 @@

mhash_keygen_ext(KEYGEN_S2K_SALTED, data, key, keysize, password, passlen);
Expand Down
32 changes: 15 additions & 17 deletions app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=7

DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
DESCRIPTION="Library providing a uniform interface to a large number of hash algorithms"
HOMEPAGE="http://mhash.sourceforge.net/"
SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"

Expand All @@ -15,26 +15,23 @@ IUSE="static-libs"
BDEPEND="dev-lang/perl" # pod2html

PATCHES=(
"${FILESDIR}/${PN}-0.9.9-fix-mem-leak.patch"
"${FILESDIR}/${PN}-0.9.9-fix-snefru-segfault.patch"
"${FILESDIR}/${PN}-0.9.9-fix-whirlpool-segfault.patch"
"${FILESDIR}/${PN}-0.9.9-autotools-namespace-stomping.patch"
"${FILESDIR}/${P}-remove_premature_free.patch"
"${FILESDIR}/${P}-force64bit-tiger.patch"
"${FILESDIR}/${P}-align.patch"
"${FILESDIR}/${P}-alignment.patch"
"${FILESDIR}"/${PN}-0.9.9-fix-mem-leak.patch
"${FILESDIR}"/${PN}-0.9.9-fix-snefru-segfault.patch
"${FILESDIR}"/${PN}-0.9.9-fix-whirlpool-segfault.patch
"${FILESDIR}"/${PN}-0.9.9-autotools-namespace-stomping.patch
"${FILESDIR}"/${P}-remove_premature_free.patch
"${FILESDIR}"/${P}-force64bit-tiger.patch
"${FILESDIR}"/${P}-align.patch
"${FILESDIR}"/${P}-alignment.patch
)

DOCS=(
doc/example.c
doc/skid2-authentication
)
HTML_DOCS=(
doc/mhash.html
)
DOCS=( doc/example.c doc/skid2-authentication )

HTML_DOCS=( doc/mhash.html )

src_prepare() {
default

sed -i \
-e 's/--netscape//' \
"${S}"/doc/Makefile.in || die
Expand All @@ -49,10 +46,11 @@ src_configure() {

src_compile() {
default

emake -C doc mhash.html
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
find "${ED}" -name '*.la' -delete || die
}

0 comments on commit 3ef9576

Please sign in to comment.