Skip to content

Commit

Permalink
dev-python/testtools: extend twisted test dep to py3.13
Browse files Browse the repository at this point in the history
Some tests need to be addapted for dev-python/twisted-24.3.0_p20240628
snapshot we have in our tree. The patch is backported from upstream.

Signed-off-by: Petr Vaněk <[email protected]>
  • Loading branch information
arkamar committed Jul 1, 2024
1 parent d2ca294 commit 3efda58
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 3 deletions.
45 changes: 45 additions & 0 deletions dev-python/testtools/files/testtools-2.7.2-twisted-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
From 5b8cb6497c7159f593e68de6a13e15f7e78e56e3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20Van=C4=9Bk?= <[email protected]>
Date: Mon, 1 Jul 2024 10:00:05 +0200
Subject: [PATCH] Prepare tests for upcoming twisted version

Twisted recently changed behavior of logger on failures [1]. It newly
logs the `Main loop terminated.` even on exceptions, which breaks two
test in twistedsupport test suite. This hack attempts to address the
upcoming issue.

[1] https://github.com/twisted/twisted/pull/12207

Upstream-PR: https://github.com/testing-cabal/testtools/pull/387

diff --git a/testtools/tests/twistedsupport/test_runtest.py b/testtools/tests/twistedsupport/test_runtest.py
index 4b46cc64..f8faf7c6 100644
--- a/testtools/tests/twistedsupport/test_runtest.py
+++ b/testtools/tests/twistedsupport/test_runtest.py
@@ -16,7 +16,6 @@
Contains,
ContainsAll,
ContainsDict,
- EndsWith,
Equals,
Is,
KeysEqual,
@@ -749,7 +748,7 @@ def test_something(self):
test,
{
"traceback": Not(Is(None)),
- "twisted-log": AsText(EndsWith(" foo\n")),
+ "twisted-log": AsText(Contains(" foo\n")),
},
),
("stopTest", test),
@@ -790,7 +789,8 @@ def test_something(self):
result = self.make_result()
runner.run(result)
self.assertThat(
- messages, MatchesListwise([ContainsDict({"message": Equals(("foo",))})])
+ messages[0:1],
+ MatchesListwise([ContainsDict({"message": Equals(("foo",))})]),
)

def test_restore_observers(self):
8 changes: 5 additions & 3 deletions dev-python/testtools/testtools-2.7.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -27,12 +27,14 @@ BDEPEND="
>=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
dev-python/testscenarios[${PYTHON_USEDEP}]
dev-python/testresources[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/twisted[${PYTHON_USEDEP}]
' 3.{10..12})
dev-python/twisted[${PYTHON_USEDEP}]
)
"

PATCHES=(
"${FILESDIR}/${PN}-2.7.2-twisted-fix.patch"
)

distutils_enable_sphinx doc

python_test() {
Expand Down

0 comments on commit 3efda58

Please sign in to comment.