forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
Showing
3 changed files
with
365 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ejabberd-16.09.tar.gz 1687485 SHA256 7b44ab3af3310ca73624c47b65cf30a651d5a1398413e8af51c610d788fb8f14 SHA512 506365eff83f9ab97c9a632c4b8b2428aacbfc570c34ca65a78903d95c64755489ff7327be3efa2172c9d05d7891f83986b1ff3928a7ce806c0ab2aa5dbb647f WHIRLPOOL 6c56ad58b4e247cedf29cf247fdadddf727270311a0ba21eef88f84ee6b997ad8be75448e3bfdaa67d978ea167e2feb21bc9ce0839741a62fb60fa045e45edf2 | ||
DIST ejabberd-17.01.tar.gz 1638418 SHA256 7efa8f25fe01bce876f9379ba7b4f49752a0fddc6a78e5ae82196fdc7f70c90b SHA512 d64125f81efbf841eded140d877c950439c11e65377e167994d25f85fa66437aad771d94548d063900bd3c472922e6bfa8f8bbe65413f18e7b641f0ed32db566 WHIRLPOOL 7b670b087cccc6b4fb804410730571175c253e094fab6fc8c9412eae4e14b844ad38596426b4334bd751a056f940dfd60c1c06d2560af5b36061eb54553886fb | ||
DIST ejabberd-17.04.tar.gz 1690441 SHA256 b8395bc65b09f135a60320b62338258acd6056cc241e9e245fde267fb18dd3c9 SHA512 03467434dba92bd1ff2f70d78aa8fcf86fc73cb52aaaa73e4947229e1d14225e7b0d0133c3da7c8efe4c9db13aab932f40f757be46b120d0f280f96d62c203d7 WHIRLPOOL c345a6b31e5ea63d72779630d7db8868e997e876ef929dc0de3df0584ca3dcbec1d36e6bb1cacdcc3ee428f9f82b4dbc73d3f08446ace0daa8beccd2fe9a8bfe |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,302 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
SSL_CERT_MANDATORY=1 | ||
|
||
inherit eutils pam rebar ssl-cert systemd | ||
|
||
DESCRIPTION="Robust, scalable and extensible XMPP server" | ||
HOMEPAGE="http://www.ejabberd.im/ https://github.com/processone/ejabberd/" | ||
SRC_URI="http://www.process-one.net/downloads/${PN}/${PV}/${P}.tgz | ||
-> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86" | ||
REQUIRED_USE="mssql? ( odbc )" | ||
# TODO: Add 'tools' flag. | ||
IUSE="captcha debug full-xml hipe ldap mssql mysql nls odbc pam postgres redis | ||
riak roster-gw sqlite zlib" | ||
|
||
RESTRICT="test" | ||
|
||
# TODO: Add dependencies for 'tools' flag enabled. | ||
# TODO: tools? ( | ||
# TODO: >=dev-erlang/meck-0.8.4 | ||
# TODO: >=dev-erlang/moka-1.0.5b | ||
# TODO: ) | ||
CDEPEND=" | ||
>=dev-erlang/cache_tab-1.0.7 | ||
>=dev-erlang/esip-1.0.11 | ||
>=dev-erlang/fast_tls-1.0.11 | ||
>=dev-erlang/fast_xml-1.1.21 | ||
>=dev-erlang/fast_yaml-1.0.9 | ||
>=dev-erlang/jiffy-0.14.8 | ||
>=dev-erlang/lager-3.2.1 | ||
>=dev-erlang/luerl-0.2 | ||
>=dev-erlang/p1_oauth2-0.6.1 | ||
>=dev-erlang/p1_utils-1.0.8 | ||
>=dev-erlang/stringprep-1.0.8 | ||
>=dev-erlang/stun-1.0.10 | ||
>=dev-erlang/xmpp-1.1.9 | ||
>=dev-lang/erlang-17.1[hipe?,odbc?,ssl] | ||
>=net-im/jabber-base-0.01 | ||
ldap? ( =net-nds/openldap-2* ) | ||
mysql? ( >=dev-erlang/p1_mysql-1.0.2 ) | ||
nls? ( >=dev-erlang/iconv-1.0.4 ) | ||
odbc? ( dev-db/unixODBC ) | ||
pam? ( >=dev-erlang/epam-1.0.2 ) | ||
postgres? ( >=dev-erlang/p1_pgsql-1.1.2 ) | ||
redis? ( >=dev-erlang/eredis-1.0.8 ) | ||
riak? ( | ||
>=dev-erlang/hamcrest-0.1.0_p20150103 | ||
>=dev-erlang/riakc-2.4.1 | ||
) | ||
sqlite? ( >=dev-erlang/sqlite3-1.1.5 ) | ||
zlib? ( >=dev-erlang/ezlib-1.0.2 )" | ||
DEPEND="${CDEPEND} | ||
>=sys-apps/gawk-4.1" | ||
RDEPEND="${CDEPEND} | ||
captcha? ( media-gfx/imagemagick[truetype,png] )" | ||
|
||
DOCS=( README ) | ||
PATCHES=( "${FILESDIR}/${P}-ejabberdctl.patch" ) | ||
|
||
EJABBERD_CERT="${EPREFIX}/etc/ssl/ejabberd/server.pem" | ||
# Paths in net-im/jabber-base | ||
JABBER_ETC="${EPREFIX}/etc/jabber" | ||
JABBER_LOG="${EPREFIX}/var/log/jabber" | ||
JABBER_SPOOL="${EPREFIX}/var/spool/jabber" | ||
|
||
# Adjust example configuration file to Gentoo. | ||
# - Use our sample certificates. | ||
# - Correct PAM service name. | ||
adjust_config() { | ||
sed -e "s|\"/path/to/ssl.pem\"|\"${EJABBERD_CERT}\"|g" \ | ||
-e "s|\"pamservicename\"|\"xmpp\"|" \ | ||
-i "${S}/ejabberd.yml.example" \ | ||
|| die 'failed to adjust example config' | ||
} | ||
|
||
# Set paths to ejabberd lib directory consistently to point always to directory | ||
# suffixed with version. | ||
correct_ejabberd_paths() { | ||
sed -e "/^EJABBERDDIR[[:space:]]*=/{s:ejabberd:${P}:}" \ | ||
-i "${S}/Makefile.in" \ | ||
|| die 'failed to set ejabberd path in Makefile.in' | ||
sed -e "/EJABBERD_BIN_PATH=/{s:ejabberd:${P}:}" \ | ||
-i "${S}/ejabberdctl.template" \ | ||
|| die 'failed to set ejabberd path in ejabberdctl.template' | ||
sed -e 's|\(captcha_cmd:[[:space:]]*"\).\+"|\1'$(get_ejabberd_path)'/priv/bin/captcha.sh"|' \ | ||
-i "${S}/ejabberd.yml.example" \ | ||
|| die 'failed to correct path to captcha.sh in example config' | ||
} | ||
|
||
# Get epam-wrapper from 'files' directory and correct path to lib directory in | ||
# it. epam-wrapper is placed into work directory. It is assumed no epam-wrapper | ||
# file exists there already. | ||
customize_epam_wrapper() { | ||
local epam_wrapper_src="$1" | ||
local epam_wrapper_dst="${S}/epam-wrapper" | ||
|
||
[[ -e ${epam_wrapper_dst} ]] && die 'epam-wrapper already exists' | ||
sed -r -e "s@^(ERL_LIBS=).*\$@\1${EPREFIX}$(get_erl_libs)@" \ | ||
"${epam_wrapper_src}" >"${epam_wrapper_dst}" \ | ||
|| die 'failed to install epam-wrapper' | ||
} | ||
|
||
# Check if there already exists a certificate. | ||
ejabberd_cert_exists() { | ||
local cert | ||
|
||
for cert in $(gawk -- \ | ||
'match($0, /^[[:space:]]*certfile: "([^"]+)"/, m) {print m[1];}' \ | ||
"${EROOT%/}${JABBER_ETC}/ejabberd.yml"); do | ||
[[ -f ${cert} ]] && return 0 | ||
done | ||
|
||
return 1 | ||
} | ||
|
||
# Generate and install sample ejabberd certificate. It's installed into | ||
# EJABBERD_CERT path. | ||
ejabberd_cert_install() { | ||
SSL_ORGANIZATION="${SSL_ORGANIZATION:-ejabberd XMPP Server}" | ||
install_cert "${EJABBERD_CERT%.*}" | ||
chown root:jabber "${EROOT%/}${EJABBERD_CERT}" || die | ||
chmod 0440 "${EROOT%/}${EJABBERD_CERT}" || die | ||
} | ||
|
||
# Get path to ejabberd lib directory. | ||
# | ||
# This is the path ./configure script Base for this path is path set in | ||
# ./configure script which is /usr/lib by default. If libdir is explicitely set | ||
# to something else than this should be adjusted here as well. | ||
get_ejabberd_path() { | ||
echo "/usr/$(get_libdir)/${P}" | ||
} | ||
|
||
# Make ejabberd.service for systemd from upstream provided template. | ||
make_ejabberd_service() { | ||
sed -r \ | ||
-e 's!@ctlscriptpath@!/usr/sbin!' \ | ||
-e 's!(User|Group)=(.*)!\1=jabber!' \ | ||
"${PN}.service.template" >"${PN}.service" \ | ||
|| die 'failed to make ejabberd.service' | ||
} | ||
|
||
# Set paths to defined by net-im/jabber-base. | ||
set_jabberbase_paths() { | ||
sed -e "/^ETCDIR[[:space:]]*=/{s:@sysconfdir@/ejabberd:${JABBER_ETC}:}" \ | ||
-e "/^LOGDIR[[:space:]]*=/{s:@localstatedir@/log/ejabberd:${JABBER_LOG}:}" \ | ||
-e "/^SPOOLDIR[[:space:]]*=/{s:@localstatedir@/lib/ejabberd:${JABBER_SPOOL}:}" \ | ||
-i "${S}/Makefile.in" \ | ||
|| die 'failed to set paths in Makefile.in' | ||
sed -e "s|\(ETC_DIR=\){{sysconfdir}}.*|\1${JABBER_ETC}|" \ | ||
-e "s|\(LOGS_DIR=\){{localstatedir}}.*|\1${JABBER_LOG}|" \ | ||
-e "s|\(SPOOL_DIR=\){{localstatedir}}.*|\1${JABBER_SPOOL}|" \ | ||
-i "${S}/ejabberdctl.template" \ | ||
|| die 'failed to set paths ejabberdctl.template' | ||
} | ||
|
||
# Skip installing docs because it's only COPYING that's installed by Makefile. | ||
skip_docs() { | ||
gawk -i inplace ' | ||
/# Documentation/, /^[[:space:]]*#?[[:space:]]*$/ { | ||
if ($0 ~ /^[[:space:]]*#?[[:space:]]*$/) { | ||
print $0; | ||
} else { | ||
next; | ||
} | ||
} | ||
1 | ||
' "${S}/Makefile.in" || die 'failed to remove docs section from Makefile.in' | ||
} | ||
|
||
pkg_setup() { | ||
if use pam; then | ||
einfo "Adding jabber user to epam group to allow ejabberd to use PAM" \ | ||
"authentication" | ||
# See | ||
# <https://docs.ejabberd.im/admin/configuration/#pam-authentication>. | ||
# epam binary is installed by dev-erlang/epam package, therefore SUID | ||
# is set by that package. Instead of jabber group it uses epam group, | ||
# therefore we need to add jabber user to epam group. | ||
usermod -a -G epam jabber || die | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
rebar_remove_deps | ||
correct_ejabberd_paths | ||
set_jabberbase_paths | ||
make_ejabberd_service | ||
skip_docs | ||
adjust_config | ||
customize_epam_wrapper "${FILESDIR}/epam-wrapper" | ||
|
||
rebar_fix_include_path fast_xml | ||
rebar_fix_include_path p1_utils | ||
rebar_fix_include_path xmpp | ||
|
||
# Fix bug #591862. ERL_LIBS should point directly to ejabberd directory | ||
# rather than its parent which is default. That way ejabberd directory | ||
# takes precedence is module lookup. | ||
local ejabberd_erl_libs="$(get_ejabberd_path):$(get_erl_libs)" | ||
sed -e "s|\(ERL_LIBS=\){{libdir}}.*|\1${ejabberd_erl_libs}|" \ | ||
-i "${S}/ejabberdctl.template" \ | ||
|| die 'failed to set ERL_LIBS in ejabberdctl.template' | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--docdir="${EPREFIX}/usr/share/doc/${PF}/html" \ | ||
--enable-user=jabber \ | ||
$(use_enable debug) \ | ||
$(use_enable full-xml) \ | ||
$(use_enable hipe) \ | ||
$(use_enable mssql) \ | ||
$(use_enable mysql) \ | ||
$(use_enable nls iconv) \ | ||
$(use_enable odbc) \ | ||
$(use_enable pam) \ | ||
$(use_enable postgres pgsql) \ | ||
$(use_enable redis) \ | ||
$(use_enable riak) \ | ||
$(use_enable roster-gw roster-gateway-workaround) \ | ||
$(use_enable sqlite) \ | ||
$(use_enable zlib) | ||
} | ||
|
||
src_compile() { | ||
emake REBAR='rebar -v' src | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
if use pam; then | ||
local epam_path="$(get_ejabberd_path)/priv/bin/epam" | ||
|
||
pamd_mimic_system xmpp auth account || die "cannot create pam.d file" | ||
into "$(get_ejabberd_path)/priv" | ||
newbin epam-wrapper epam | ||
fi | ||
|
||
newconfd "${FILESDIR}/${PN}.confd" "${PN}" | ||
newinitd "${FILESDIR}/${PN}.initd" "${PN}" | ||
systemd_dounit "${PN}.service" | ||
systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf" | ||
|
||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}/${PN}.logrotate" "${PN}" | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ ! ${REPLACING_VERSIONS} ]]; then | ||
echo | ||
elog "For configuration instructions, please see" | ||
elog " http://www.process-one.net/en/ejabberd/docs/" | ||
echo | ||
if [[ " ${REPLACING_VERSIONS} " =~ \ 2\. ]]; then | ||
ewarn "If you have used pubsub in ejabberd-2.* you may encounter issues after" | ||
ewarn "migration to ${PV}. pubsub data may not be migrated automatically and" | ||
ewarn "you may need to run migration script manually, see:" | ||
ewarn | ||
ewarn " https://github.com/processone/ejabberd/issues/479#issuecomment-124497456" | ||
ewarn | ||
ewarn "In case you don't care about all stored moods, activities, geoinfo and you" | ||
ewarn "know you don't store in pubsub anything important, you can just remove" | ||
ewarn "pubsub tables:" | ||
ewarn | ||
ewarn " rm ${EROOT%/}${JABBER_SPOOL}/pubsub_*" | ||
ewarn | ||
ewarn "See also: https://bugs.gentoo.org/show_bug.cgi?id=588244" | ||
echo | ||
fi | ||
elif [[ -f ${EROOT}etc/jabber/ejabberd.cfg ]]; then | ||
elog "Ejabberd now defaults to using a YAML format for its config file." | ||
elog "The old ejabberd.cfg file can be converted using the following instructions:" | ||
echo | ||
elog "1. Make sure all processes related to the previous version of ejabberd aren't" | ||
elog " running. Usually this just means the ejabberd and epmd daemons and possibly" | ||
elog " the pam-related process (epam) if pam support is enabled." | ||
elog "2. Run \`ejabberdctl start\` with sufficient permissions. Note that this can" | ||
elog " fail to start ejabberd properly for various reasons. Check ejabberd's main" | ||
elog " log file at /var/log/jabber/ejabberd.log to confirm it started successfully." | ||
elog "3. Run" | ||
elog " \`ejabberdctl convert_to_yaml /etc/jabber/ejabberd.cfg /etc/jabber/ejabberd.yml.new\`" | ||
elog " with sufficient permissions, edit and rename /etc/jabber/ejabberd.yml.new to" | ||
elog " /etc/jabber/ejabberd.yml, and finally restart ejabberd with the new config" | ||
elog " file." | ||
echo | ||
fi | ||
|
||
if ! ejabberd_cert_exists; then | ||
ejabberd_cert_install | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
From 185923a3c5f11c2d29599416a52b6594bc94d8c9 Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <[email protected]> | ||
Date: Mon, 29 Aug 2016 22:29:41 +0100 | ||
Subject: [PATCH] Adjust ejabberdctl for Gentoo jabberbase setup | ||
|
||
Set SHELL since the generic jabber user used on Gentoo for jabber | ||
servers doesn't have a valid shell set by default and fix EXEC_CMD | ||
otherwise it fails with "This account is currently not available" again | ||
due to jabber not having a valid shell. | ||
|
||
Also, workaround the assumption that jabber's $HOME is a directory when | ||
instead it defaults to /dev/null on Gentoo. | ||
--- | ||
ejabberdctl.template | 8 ++++++-- | ||
1 file changed, 6 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/ejabberdctl.template b/ejabberdctl.template | ||
index 5b34ebe..3c080fd 100755 | ||
--- a/ejabberdctl.template | ||
+++ b/ejabberdctl.template | ||
@@ -16,6 +16,7 @@ IEX={{bindir}}/iex | ||
EPMD={{epmd}} | ||
INSTALLUSER={{installuser}} | ||
ERL_LIBS={{libdir}} | ||
+SHELL=/bin/sh | ||
|
||
# check the proper system user is used if defined | ||
if [ "$INSTALLUSER" != "" ] ; then | ||
@@ -23,11 +24,11 @@ if [ "$INSTALLUSER" != "" ] ; then | ||
for GID in `id -G`; do | ||
if [ $GID -eq 0 ] ; then | ||
INSTALLUSER_HOME=$(getent passwd "$INSTALLUSER" | cut -d: -f6) | ||
- if [ -n "$INSTALLUSER_HOME" ] && [ ! -d "$INSTALLUSER_HOME" ] ; then | ||
+ if [ -n "$INSTALLUSER_HOME" ] && [ ! -e "$INSTALLUSER_HOME" ] ; then | ||
mkdir -p "$INSTALLUSER_HOME" | ||
chown "$INSTALLUSER" "$INSTALLUSER_HOME" | ||
fi | ||
- EXEC_CMD="su $INSTALLUSER -c" | ||
+ EXEC_CMD="su $INSTALLUSER -p -c" | ||
fi | ||
done | ||
if [ `id -g` -eq `id -g $INSTALLUSER` ] ; then | ||
@@ -91,6 +92,7 @@ EJABBERD_LOG_PATH=$LOGS_DIR/ejabberd.log | ||
DATETIME=`date "+%Y%m%d-%H%M%S"` | ||
ERL_CRASH_DUMP=$LOGS_DIR/erl_crash_$DATETIME.dump | ||
ERL_INETRC=$ETC_DIR/inetrc | ||
+HOME=$SPOOL_DIR | ||
|
||
# define mnesia options | ||
MNESIA_OPTS="-mnesia dir \"\\\"$SPOOL_DIR\\\"\" $MNESIA_OPTIONS" | ||
@@ -149,6 +151,8 @@ export ERL_MAX_ETS_TABLES | ||
export CONTRIB_MODULES_PATH | ||
export CONTRIB_MODULES_CONF_DIR | ||
export ERL_LIBS | ||
+export HOME | ||
+export SHELL | ||
|
||
shell_escape_str() | ||
{ | ||
-- | ||
2.9.2 | ||
|