forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libopenshot-audio: bump to 0.1.2
Package-Manager: portage-2.3.0 Closes: gentoo#2304 Signed-off-by: David Seifert <[email protected]>
- Loading branch information
1 parent
61b2e8e
commit 3f26206
Showing
2 changed files
with
36 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST libopenshot-audio-0.0.6.tar.gz 2963454 SHA256 29707bf7603fc08b2a152abff2599405f3499a2d674919b1a1749638cd91f42e SHA512 20ea1805134f899d845469dacca6bb86eaa6e6cb55cea22acca0ff5e4261782ecdedaa44454e2eb449183a985130861d305402f5cce37da4624650a786167993 WHIRLPOOL 1d9638ebc268190e2ef9c4ad93e1b4c86734940488660e65beef4f4362b2e9a1b5602f0717918ded89b8d588251d3fedff91cfd41c9425fb6d63c408b332478c | ||
DIST libopenshot-audio-0.1.2.tar.gz 2964758 SHA256 fc03a081feffa424c303a30720cece200222cb28c92e21c4b680d88cb42260d9 SHA512 955f9c20ebf06474702208845fe49d031e29b0614fd15c0e1784c52d1c406fb7a980940bba1f297543305a9611fefd6b9232328cd39c5edbc8908018c5b12f1c WHIRLPOOL 6a46b7fbda690becd28f166285d26fbf21aaca80c7b88fb28e69d9c3482f705ea40c256d8192f686878b5c3f1f0cf95e4b29bfd55c73b818122ab7f303a883cd |
35 changes: 35 additions & 0 deletions
35
media-libs/libopenshot-audio/libopenshot-audio-0.1.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils | ||
|
||
DESCRIPTION="Audio library used by OpenShot" | ||
HOMEPAGE="http://www.openshot.org/ https://launchpad.net/libopenshot" | ||
SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=" | ||
media-libs/alsa-lib | ||
media-libs/freetype | ||
x11-libs/libX11 | ||
x11-libs/libXext | ||
" | ||
DEPEND=" | ||
x11-libs/libXinerama | ||
x11-libs/libXrandr | ||
${RDEPEND} | ||
" | ||
|
||
src_prepare() { | ||
# fix under-linking | ||
# https://github.com/OpenShot/libopenshot-audio/issues/3 | ||
sed -i 's/^\(target_link_libraries(.*\))$/\1 dl pthread)/' \ | ||
src/CMakeLists.txt || die | ||
cmake-utils_src_prepare | ||
} |