Skip to content

Commit

Permalink
dev-libs/libnl: Add dev-lang/python:3.5 support.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
Jeroen Roovers committed Sep 11, 2016
1 parent 5f7630b commit 3f50a29
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 18 deletions.
21 changes: 14 additions & 7 deletions dev-libs/libnl/libnl-3.2.28.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4} )
PYTHON_COMPAT=( python2_7 python3_{4,5} )
DISTUTILS_OPTIONAL=1
inherit distutils-r1 eutils libtool multilib multilib-minimal

Expand All @@ -21,20 +21,27 @@ SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="static-libs python utils"

RDEPEND="python? ( ${PYTHON_DEPS} )
RDEPEND="
python? ( ${PYTHON_DEPS} )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r5
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}
)
"
DEPEND="
${RDEPEND}
python? ( dev-lang/swig )
sys-devel/flex
sys-devel/bison
sys-devel/flex
"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"

DOCS=( ChangeLog )
DOCS=(
ChangeLog
)

S=${WORKDIR}/${LIBNL_P}

Expand Down
30 changes: 19 additions & 11 deletions dev-libs/libnl/libnl-3.2.9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4} )
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1 eutils git-r3 libtool multilib multilib-minimal

Expand All @@ -17,20 +17,30 @@ SLOT="3"
KEYWORDS=""
IUSE="static-libs python utils"

RDEPEND="python? ( ${PYTHON_DEPS} )
RDEPEND="
python? ( ${PYTHON_DEPS} )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r5
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}
)
"
DEPEND="
${RDEPEND}
python? ( dev-lang/swig )
sys-devel/flex
sys-devel/bison
sys-devel/flex
"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DOCS=( ChangeLog )
DOCS=(
ChangeLog
)
PATCHES=(
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
"${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
"${FILESDIR}"/${PN}-3.2.20-cache-api.patch
)

MULTILIB_WRAPPED_HEADERS=(
# we do not install CLI stuff for non-native
Expand All @@ -49,9 +59,7 @@ MULTILIB_WRAPPED_HEADERS=(
)

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
epatch "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
epatch "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
default

eautoreconf

Expand Down

0 comments on commit 3f50a29

Please sign in to comment.