Skip to content

Commit

Permalink
media-libs/liblrdf: add libressl support
Browse files Browse the repository at this point in the history
  • Loading branch information
Julian Ospald committed Oct 4, 2015
1 parent da5485e commit 3f5f773
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions media-libs/liblrdf/liblrdf-0.5.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools

DESCRIPTION="A library for the manipulation of RDF file in LADSPA plugins"
HOMEPAGE="https://github.com/swh/LRDF"
SRC_URI="https://github.com/swh/LRDF/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="libressl static-libs"

RDEPEND="
!libressl? ( >=dev-libs/openssl-1:0 )
libressl? ( dev-libs/libressl )
media-libs/raptor:2
>=media-libs/ladspa-sdk-1.12"
DEPEND="${RDEPEND}
virtual/pkgconfig"

DOCS=( AUTHORS ChangeLog README )

src_unpack() {
unpack ${A}
mv *-LRDF-* "${S}"
}

src_prepare() {
sed -i -e 's:usr/local:usr:' examples/{instances,remove}_test.c || die #392221
eautoreconf
}

src_configure() {
econf $(use_enable static-libs static)
}

src_test() {
has_version media-plugins/swh-plugins && default #392221
}

src_install() {
default
rm -f "${ED}"usr/lib*/liblrdf.la
}

0 comments on commit 3f5f773

Please sign in to comment.