Skip to content

Commit

Permalink
dev-util/cscope: addp Prefix changes and keywords, bug #607712
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
grobian committed Jan 31, 2017
1 parent 041a10e commit 3f5fdce
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
70 changes: 70 additions & 0 deletions dev-util/cscope/cscope-15.8a-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools elisp-common toolchain-funcs

DESCRIPTION="Interactively examine a C program"
HOMEPAGE="http://cscope.sourceforge.net/"
SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"

LICENSE="BSD GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="emacs"

RDEPEND=">=sys-libs/ncurses-5.2:0=
emacs? ( virtual/emacs )"
DEPEND="${RDEPEND}
sys-devel/flex
virtual/pkgconfig
virtual/yacc"

SITEFILE="50${PN}-gentoo.el"

src_prepare() {
eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
eapply "${FILESDIR}/${PN}-15.6-darwin.patch"
eapply_user
mv configure.{in,ac} || die
eautoreconf # prevent maintainer mode later on
}

src_configure() {
econf --with-ncurses="${EPREFIX}"/usr
}

src_compile() {
emake CURSES_LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-compile *.el
fi
}

src_install() {
default

if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dobin cscope-indexer
fi

cd "${S}"/contrib/webcscope || die
docinto webcscope
dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
docinto webcscope/icons
dodoc icons/*.gif
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}
11 changes: 11 additions & 0 deletions dev-util/cscope/files/cscope-15.6-darwin.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/src/constants.h
+++ b/src/constants.h
@@ -103,7 +103,7 @@
#define INCLUDES 8
#define FIELDS 9

-#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__
+#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__ && !__MACH__
# define TERMINFO 0 /* no terminfo curses */
#else
# define TERMINFO 1

0 comments on commit 3f5fdce

Please sign in to comment.