Skip to content

Commit

Permalink
dev-db/etcd: Version bump to 3.1.9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
mrueg committed Jun 12, 2017
1 parent 74d2c9a commit 3f6545e
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/etcd/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST etcd-3.0.17.tar.gz 2208002 SHA256 c56c68a8cd5d120a51432f3a79a2c19082a682449
DIST etcd-3.1.0.tar.gz 2516872 SHA256 62ecb70a470b45436814e2882d36742a4035e1d62e6634450e71ca0ed951919b SHA512 b377ac492dd842a0f24d2816cd37bb40e692289efbbab63ab54e1b31e7999f26c6c0f2887249f5fd775266919a614699e561ecfc82c8a687d2cf1b25fdb7478f WHIRLPOOL b47a81ea597617a4eab6ee29d51b964f942b8dc324063e6633e2818320ce3b19e1907975a28ca3186cc112553b4e8580c210ad4854945484dcc26f359d0c60e6
DIST etcd-3.1.6.tar.gz 2522712 SHA256 9bc6f280f3875f7e5dd6685c4dbe1a237306669843cced38d08ea53580bafb19 SHA512 3ff6d7c85c345d5d4515f7c8cc40c01758ef34bfe65a8f23149dfea5037e4dee5c382e3a28c17d7e8865b8e916c2e61cc350277c9e5be7f5b7853c4f59a2bfe3 WHIRLPOOL 87f9835a1a6ed40bcfedb051973140e81b72874da6be22777f70e8a2a6046a2be5ebd00b2e98220d77eb185ef9e044032cc2fbfc2513187633b606b9087347c2
DIST etcd-3.1.8.tar.gz 2524139 SHA256 f68700f710dfd9c5fefb41a60e96f9d0c7907e6abe21518ab0a05f6e425a3d4e SHA512 8228f4556501fbc860eb381df9ec806be0973cc92550e1285f88800575760ee7f0bc277edb6c32eb3b7c6bea7af3a1074986c9ceb6b4d97166623f16bc3dc36a WHIRLPOOL 1edca7e720d76f4b532a805e096cc33289c2fc981b11fc37d4327aead394aaddc89f199f65392e0b3b2caa14bc9c8e6abf62895fd0fbf8eaef8e9c74ba09f4b9
DIST etcd-3.1.9.tar.gz 2524517 SHA256 94cf6a970ca707eec16e3264b8cd20ef8963d0683958ef087b52f490ab784a6f SHA512 e4727f2bafaf38c139608726947258f3ae3aa91452b145710ff527f5b57cbda18474902450581882e668befc422f6a1b9f1232a23e3eeedefae2ed2da1814cfc WHIRLPOOL c0241b76220cfccc331db3caf19c1ab33485b0219d31656a26e577c0ae9ae606f17f05b34a1c58644b24a2a712b61982429c25489923892ccb09806ac0a2eb24
60 changes: 60 additions & 0 deletions dev-db/etcd/etcd-3.1.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit user systemd golang-vcs-snapshot

KEYWORDS="~amd64"
EGO_PN=github.com/coreos/etcd
DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
HOMEPAGE="https://github.com/coreos/etcd"
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc"
DEPEND=">=dev-lang/go-1.6:="
RDEPEND="!dev-db/etcdctl"

src_prepare() {
eapply_user
sed -e 's|GIT_SHA=.*|GIT_SHA=v${PV}|'\
-i "${S}"/src/${EGO_PN}/build || die
}

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
}

src_compile() {
export GOPATH=${S}
cd "${S}"/src/${EGO_PN} || die
./build || die
}

src_install() {
cd "${S}"/src/${EGO_PN} || die
insinto /etc/${PN}
doins "${FILESDIR}/${PN}.conf"
dobin bin/*
dodoc README.md
use doc && dodoc -r Documentation
systemd_dounit "${FILESDIR}/${PN}.service"
systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
dodir /var/lib/${PN}
fowners ${PN}:${PN} /var/lib/${PN}
fperms 755 /var/lib/${PN}
dodir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
fperms 755 /var/log/${PN}
}

src_test() {
cd "${S}"/src/${EGO_PN} || die
./test || die
}

0 comments on commit 3f6545e

Please sign in to comment.