Skip to content

Commit

Permalink
dev-php/pecl-mongodb: Version bump for 1.4.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Brian Evans committed Mar 6, 2018
1 parent 03617de commit 3f79ddb
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-mongodb/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mongodb-1.1.8.tgz 806900 BLAKE2B 2d15bb3bc139464c0f411e86405277a7adeb0bfd1d
DIST mongodb-1.2.11.tgz 786669 BLAKE2B 69c0689436f73846294f13610d569c2bdd4fc0614d179939d2c2ae67d40f9f0f2d265b1d3560e2bfe652aa36e9ad862f547530e5ae22c9f85a05a86a429b3b49 SHA512 19642bc156064e14c598b09a328b57c2f7c35c59268912edb88bbd1a144e5f2ea5a74860c3b9fb8552e45114cf712d7acf6f686486db328b34f0583aac8766f5
DIST mongodb-1.2.9.tgz 786049 BLAKE2B 39c1ea211fdaa116e5a25fdb17a7be8b6c375909fc8a46bbcd7ed9f5d7a528f1effccec81000b61ed784fb924196237fb9cea74969cc0754dd53cb202377e800 SHA512 7eff5cfce08f3d69bc7acdb9ab5f8f55d02dab67593e5d03402c8bb6b6611fd703e8dfda89b99e8d3de387ed58cb9eea096fe68e0c9657ec3f8b1b7f622cfe58
DIST mongodb-1.3.3.tgz 925476 BLAKE2B 845abd4c7cf5dbb1fb3b04c5fc4070f0a360874ac566f1988025701258141a89afaa0e60c3d7166484fa37eda4ef08d94deeabdcc2ebe2a4f221dcf83aff20df SHA512 16c82ada278eac6996065d3c594237fbb8c1a7fe4e21828aa8af9ef98033cf6dfaf0fee90095e8116e946e620b551a6122238f85865a6c47d4d087f784cd54ea
DIST mongodb-1.4.1.tgz 1037836 BLAKE2B eb31be94e1508a860d88d44e3e6714bea62a34eb999285a2e40082a0b66b617d380adbbf56614244eb567b8939dae223b0553d425e608d05d86cd3232441b59d SHA512 4c053917ba6e178e114a4aafcd20ec505694bd96575235485e1524f1063d17ea1c446c86b7eb70d0c25db4ae6338d71fb33aa9df647ce1c80a17f539362230b0
40 changes: 40 additions & 0 deletions dev-php/pecl-mongodb/pecl-mongodb-1.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_EXT_NAME="mongodb"
USE_PHP="php5-6 php7-0 php7-1 php7-2"

inherit php-ext-pecl-r3

DESCRIPTION="MongoDB database driver for PHP"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libressl sasl"

RDEPEND="
php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
php_targets_php7-2? ( dev-lang/php:7.2[json,ssl,zlib] )
>=dev-libs/libbson-1.9.0
>=dev-libs/mongo-c-driver-1.9.0[sasl?,ssl]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sasl? ( dev-libs/cyrus-sasl )
"
# pkgconfig needed if system libraries are used for bson and libmongoc
DEPEND="${RDEPEND} virtual/pkgconfig"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-mongodb
--with-libbson
--with-libmongoc
--with-mongodb-sasl=$(usex sasl)
)
php-ext-source-r3_src_configure
}

0 comments on commit 3f79ddb

Please sign in to comment.