Skip to content

Commit

Permalink
games-puzzle/xtris: [QA] fix tc-get* quoting
Browse files Browse the repository at this point in the history
This can cause build problems for e.g. 32-bit (gcc -m32 ...)

Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Mar 19, 2022
1 parent 493d545 commit 3f82cc0
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
Fixes:
xtbot.c:211:23: warning: implicit declaration of function ‘time’; did you mean ‘utimes’? [-Wimplicit-function-declaration]
xtserv.c:386:23: warning: implicit declaration of function ‘time’; did you mean ‘utimes’? [-Wimplicit-function-declaration]
--- a/xtbot.c
+++ b/xtbot.c
@@ -23,6 +23,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <time.h>
#include <sys/types.h>
#include <sys/time.h>
#include <sys/socket.h>
--- a/xtserv.c
+++ b/xtserv.c
@@ -15,6 +15,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <fcntl.h>
+#include <time.h>
#include <sys/types.h>
#include <sys/time.h>
#include <signal.h>
10 changes: 7 additions & 3 deletions games-puzzle/xtris/xtris-1.15-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

inherit desktop toolchain-funcs

Expand All @@ -17,9 +17,13 @@ KEYWORDS="~amd64 ~x86"
DEPEND="x11-libs/libX11"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-1.15-implicit-function-decl-time.patch
)

src_compile() {
emake \
CC=$(tc-getCC) \
CC="$(tc-getCC)" \
BINDIR=/usr/bin \
MANDIR=/usr/share/man \
CFLAGS="${CFLAGS}" \
Expand Down

0 comments on commit 3f82cc0

Please sign in to comment.