Skip to content

Commit

Permalink
dev-python/pyproj: Bump to 3.1.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 25, 2021
1 parent 8e59196 commit 3fbfbfc
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyproj/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
DIST pyproj-3.1.0.tar.gz 182603 BLAKE2B d4e95f62b10b282e7bbfcb7a2059a11a489e53402cbb1760b7da73248dfc05de6be8ca820e55d34c9270eea38178f1fb934bd5ffc389833b3734b87b79991187 SHA512 21a5d08207676d8d9722cb5e3b13ed68f03b1a2aa034c20c61bb8dab5d204dd968ba9a3df1b0c43ed174e082725c7624efb75a0c9c3df920808cbcb44f4d170a
49 changes: 49 additions & 0 deletions dev-python/pyproj/pyproj-3.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1

DESCRIPTION="Python interface to the PROJ library"
HOMEPAGE="https://github.com/pyproj4/pyproj"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
S="${WORKDIR}/${P/_p/.post}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"

RDEPEND=">=sci-libs/proj-7.2.0:="
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/xarray[${PYTHON_USEDEP}]
sci-libs/shapely[${PYTHON_USEDEP}]
)"

distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
distutils_enable_tests --install pytest

python_test() {
local deselect=(
# TODO
test/test_datum.py
test/test_transformer.py::test_transform_wgs84_to_alaska
test/test_transformer.py::test_repr__conditional
test/test_transformer.py::test_transformer_group__unavailable
test/test_transformer.py::test_transformer_group__network_disabled
test/test_transformer.py::test_transformer_group__download_grids__directory
test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
)

distutils_install_for_testing
cp -r test "${BUILD_DIR}" || die
cd "${BUILD_DIR}" || die
epytest --import-mode=append -m "not network" \
${deselect[@]/#/--deselect } test
}

0 comments on commit 3fbfbfc

Please sign in to comment.