Skip to content

Commit

Permalink
dev-python/alembic: Bump to 1.7.7
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Mar 14, 2022
1 parent a611161 commit 3fd7c0f
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/alembic/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST alembic-1.7.5.tar.gz 1229596 BLAKE2B dbedcc43f60b2b28adc17b1c0c753b22993127acd5aab04bbf4a47920e11894498618d353eb544b48c0c5698d7cf6f96fba39a98df723a611810e71e24809b0e SHA512 4223116c3610f3196335c1fb2032a9a236c3e6ec4e4ca5cb85ccc3667d614e77d51d9fee1ee0173a32451198929428c1fcf39afd90b6df32584b076e0a4ab1a4
DIST alembic-1.7.6.tar.gz 1235649 BLAKE2B 5e12cf09927c7851ad5c95b7047865eec6ca01d3ce94045be3601855370e1cce8371d16ee4141a953a8ea0ffaafaa68c08499416283c7996b086b7b5967c8790 SHA512 dca97722ac70654dfa23d673b776d064af13bf1e59219131d7716d7ce183508361bad713d7d0986c8a56dd66c58a59fafc1c3b3ef80507eaf6368e48f9c1a059
DIST alembic-1.7.7.tar.gz 1247590 BLAKE2B 9906a266b71d658bd66b00b237bc21bb092646077584ddb5c245f73709087f0e476e86eb022bf041e57a68e16ee89e5a3a047dc7ec2d43ffa941b2e803aef0fe SHA512 dcb4ba2faafc3ee789981931e0548f7328c1118938150789218e720f39386fd5e7e2543ab241838bcc1faaf36db07900fd065963496e68ced0896a5f4795d63d
36 changes: 36 additions & 0 deletions dev-python/alembic/alembic-1.7.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{8..10} )

inherit distutils-r1

DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
HOMEPAGE="https://github.com/sqlalchemy/alembic"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
IUSE="doc"

RDEPEND="
>=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/importlib_metadata[${PYTHON_USEDEP}]
dev-python/importlib_resources[${PYTHON_USEDEP}]
' pypy3 python3_8)
"

distutils_enable_tests pytest

python_install_all() {
use doc && local HTML_DOCS=( docs/. )
distutils-r1_python_install_all
}

0 comments on commit 3fd7c0f

Please sign in to comment.