Skip to content

Commit

Permalink
dev-util/kdevplatform: Version bump 5.0.3
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
johu committed Dec 1, 2016
1 parent 33e0056 commit 3fff385
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/kdevplatform/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST kdevplatform-1.7.2.tar.xz 1929976 SHA256 0afcde7a746adb83b00f2bd6b02efb4022adbd61b6ba4325fb63b71902f1f4e4 SHA512 b95a1837b61d6c63cdd5183194ea70301bb32720df8c5317ba891a91c24c1e174aa69d10131024701bfe710f4848ac50059bc4513cf334d39415d37f4a445d66 WHIRLPOOL 4656a52becd50e9d827010e798941465731872b014400529fde4c45410d7f77d063c7fed237f94991742af997e845145772dbb199df74ae9777d41c2bdc21693
DIST kdevplatform-1.7.3.tar.bz2 2417125 SHA256 195134bde11672de38838f4b341ed28c58042374ca12beedacca9d30e6ab4a2b SHA512 a23712bc70a7b084541a0bb441e19ba30bf408e4046403367cfce98cf7cb60b1aa89d6fce466e5512f1d3ea93353dc0dc5b57b0953bb85e7319a4a14d5403be9 WHIRLPOOL b0deafac4013aaad4ab80ae87c5dabd033a522e935ba1569659cb8dd4e7f06b8e75910ffecc3b27c7ffe0687cfc2ba65a2d707e8fd5b96ad603d4a4b011f2864
DIST kdevplatform-5.0.2.tar.xz 1997268 SHA256 a7f311198bb72f5fee064d99055e8df39ecf4e9066fe5c0ff901ee8c24d960ec SHA512 5334130ee12fcd3bcc22f488e6e8b64192c9fa878bc4d1666f1e8f5b8ae016410843cce14e38084d455ad3004586b43304f199b0d52bb5c44817e059557da089 WHIRLPOOL 6d1c316d90993e32234faff0ba78dca1fe599078d6836999435e59b825b13c5f2301adb0e20161b1233ad838ec7d291f11e243c665834a7ae5b27c9036c9f8bd
DIST kdevplatform-5.0.3.tar.xz 2018600 SHA256 643d1145e1948af221f9ae148d0a10809f3d89af4b97ff0d6c4d571004f46bd4 SHA512 ef48c0de41d1fe20269400eea4d2b04efa04cd62caaa987e6814c5513e843c3cac030479a8a0576b9fc532d7771827fcc4acda128448ff34dec9fbd55bd05d55 WHIRLPOOL 24cbc44345867b78b669993fcc8d1b680c051cce7c6ce91761de14877f05e6f983f562fe99d0ffa2586611d7daee8d66a2a530f7700ae2c44832f9d980069099
109 changes: 109 additions & 0 deletions dev-util/kdevplatform/kdevplatform-5.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

EGIT_BRANCH="5.0"
KDEBASE="kdevelop"
KDE_TEST="forceoptional-recursive"
VIRTUALDBUS_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="KDE development support libraries and apps"
IUSE="cvs reviewboard subversion +welcomepage"
[[ ${KDE_BUILD_TYPE} = release ]] && KEYWORDS="~amd64 ~x86"

COMMON_DEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdeclarative)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep knotifyconfig)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktexteditor)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_frameworks_dep sonnet)
$(add_frameworks_dep threadweaver)
$(add_kdeapps_dep libkomparediff2)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qttest)
$(add_qt_dep qtwebkit)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
dev-libs/grantlee:5
reviewboard? ( dev-libs/purpose )
subversion? (
dev-libs/apr:1
dev-libs/apr-util:1
dev-vcs/subversion
)
welcomepage? ( $(add_qt_dep qtdeclarative 'widgets') )
"
DEPEND="${COMMON_DEPEND}
dev-libs/boost
$(add_qt_dep qtconcurrent)
"
RDEPEND="${COMMON_DEPEND}
cvs? ( dev-vcs/cvs )
!dev-util/kdevelop:4
!dev-util/kdevplatform:4
"

REQUIRED_USE="test? ( welcomepage )"

RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${PN}-5.0.1-unused-deps.patch" )

src_prepare() {
kde5_src_prepare
# root tests subdirectory actually does not contain tests, installs stuff
if ! use test; then
sed -i -e "/add_subdirectory(tests)/ s/#DONOTCOMPILE //" \
CMakeLists.txt || die "Failed to fix CMakeLists.txt"
sed -i -e '1s/^/find_package(Qt5Test \$\{QT_MIN_VERSION\})\n/' \
tests/CMakeLists.txt || die "Failed to fix tests/CMakeLists.txt"
fi
}

src_configure() {
local mycmakeargs=(
-DBUILD_cvs=$(usex cvs)
$(cmake-utils_use_find_package reviewboard KDEExperimentalPurpose)
$(cmake-utils_use_find_package subversion SubversionLibrary)
$(cmake-utils_use_find_package welcomepage Qt5QuickWidgets)
)

kde5_src_configure
}

pkg_postinst() {
kde5_pkg_postinst

if ! has_version "kde-apps/konsole" ; then
echo
elog "For konsole view, please install kde-apps/konsole"
echo
fi
}

0 comments on commit 3fff385

Please sign in to comment.