forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/harfbuzz: Bump to version 2.6.3
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Oct 29, 2019
1 parent
4bcff1c
commit 3fffca8
Showing
2 changed files
with
111 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST harfbuzz-2.6.1.tar.xz 5741372 BLAKE2B bb763eba23a37bd20d0ddb39824d5a0c655d6e098aea2e44b6943e7bd5cb1f9a5cd94e3de5520d962e3c476defac43af58f98d0a5b80e5c1506d00bc716ec876 SHA512 cea531ab9db0ae1b188ac56c3ea6e0344192c4321b97d4425f4a53e6bb34c88463a7453fd69fcadccb8574506c1fb5505422019e41a7938a04e7823e3f484c06 | ||
DIST harfbuzz-2.6.2.tar.xz 5769792 BLAKE2B 8ab4f76e858cb6d120b59c62fcda783fb331ec750ed9e4a74ceea448cafab9aff814d8599442d8939d41d0b5cc176724753b16c7cd42d6d314a08ce27d6856f5 SHA512 0a98c2b49650d66cf11f3395504cba3b18aaca43482924d9b58babd2ccb986b74ed7478bef5c4c1937d7782b7b278504854eaa04a62b329df08d91d30fc879d5 | ||
DIST harfbuzz-2.6.3.tar.xz 5811320 BLAKE2B 84f6f8346574c881b41c47561b983d0714d2754a40955cbb8fb9687cfa0cd2dea965aad1eac417ad1cb5270cd5ced27225c710f0743a408f367902e7c326b24e SHA512 ed387c551c01305d419dab186e3760959ac31abec761dde407142ad3619db918a5b79cc1e0737004f5da3437f7eabb8d796f770f0e7eba60d3a4496995453444 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,110 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils | ||
|
||
DESCRIPTION="An OpenType text shaping engine" | ||
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz" | ||
|
||
if [[ ${PV} = 9999 ]] ; then | ||
EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git" | ||
inherit git-r3 autotools | ||
else | ||
SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.xz" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
fi | ||
|
||
LICENSE="Old-MIT ISC icu" | ||
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416 | ||
|
||
IUSE="+cairo debug +glib +graphite icu +introspection static-libs test +truetype" | ||
REQUIRED_USE="introspection? ( glib )" | ||
|
||
RDEPEND=" | ||
cairo? ( x11-libs/cairo:= ) | ||
glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] ) | ||
graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] ) | ||
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] ) | ||
introspection? ( >=dev-libs/gobject-introspection-1.34:= ) | ||
truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
test? ( ${PYTHON_DEPS} ) | ||
" | ||
BDEPEND=" | ||
dev-util/gtk-doc-am | ||
virtual/pkgconfig | ||
" | ||
# eautoreconf requires gobject-introspection-common | ||
# ragel needed if regenerating *.hh files from *.rl | ||
if [[ ${PV} = 9999 ]] ; then | ||
DEPEND+=" | ||
>=dev-libs/gobject-introspection-common-1.34 | ||
dev-util/ragel | ||
" | ||
fi | ||
|
||
pkg_setup() { | ||
use test && python-any-r1_pkg_setup | ||
if ! use debug ; then | ||
append-cppflags -DHB_NDEBUG | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
xdg_environment_reset | ||
|
||
if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then | ||
# on Darwin/Solaris we need to link with g++, like automake defaults | ||
# to, but overridden by upstream because on Linux this is not | ||
# necessary, bug #449126 | ||
sed -i \ | ||
-e 's/\<LINK\>/CXXLINK/' \ | ||
src/Makefile.am || die | ||
sed -i \ | ||
-e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \ | ||
src/Makefile.in || die | ||
sed -i \ | ||
-e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \ | ||
test/api/Makefile.in || die | ||
fi | ||
|
||
[[ ${PV} == 9999 ]] && eautoreconf | ||
elibtoolize # for Solaris | ||
|
||
# bug 618772 | ||
append-cxxflags -std=c++14 | ||
} | ||
|
||
multilib_src_configure() { | ||
# harfbuzz-gobject only used for instrospection, bug #535852 | ||
local myeconfargs=( | ||
--without-coretext | ||
--without-fontconfig #609300 | ||
--without-uniscribe | ||
$(use_enable static-libs static) | ||
$(multilib_native_use_with cairo) | ||
$(use_with glib) | ||
$(use_with introspection gobject) | ||
$(use_with graphite graphite2) | ||
$(use_with icu) | ||
$(multilib_native_use_enable introspection) | ||
$(use_with truetype freetype) | ||
) | ||
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" | ||
|
||
if multilib_is_native_abi; then | ||
ln -s "${S}"/docs/html docs/html || die | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
find "${ED}" -name "*.la" -delete || die | ||
} |