Skip to content

Commit

Permalink
mate-extra/mate-sensors-applet: Bump to 1.24.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Adam Feldman <[email protected]>
  • Loading branch information
NP-Hardass committed Sep 25, 2020
1 parent 07d48ce commit 40534cc
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-sensors-applet/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-sensors-applet-1.24.0.tar.xz 580536 BLAKE2B a72198917a3b87c1a9ed941aa272cab7439bcd07cb1bb2dbadb0fcd21bb5d6f1cc05986800de7d0f68c2c260cf9556f1e239a2ad2fd01bec8bdccad0180117b2 SHA512 039834b7cfe641e670e372e311da3d737254ab3cf13b27e71c6555888ac1165766fe2d940bcea44a5ceed5f0ddcd3390d01331d927121137c21a6647c68875c2
DIST mate-sensors-applet-1.24.1.tar.xz 578964 BLAKE2B e9a7eacb032738014c3e91595ae1f2673973b20c09fd02bd186aa5468773a1322022fbb245b9ec6e9c987405014b91e0f7c12e072f9c3ba6cd9df32c1ee99703 SHA512 3bf21d501e067a2ce002c5149f42161cc6917609ceb2396b705e905987cb4d989725ca825c6de7bbe4e950f7a01e755c2cd5b45532d6f65aef690f394741489a
62 changes: 62 additions & 0 deletions mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MATE_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="MATE panel applet to display readings from hardware sensors"
LICENSE="FDL-1.1+ GPL-2+"
SLOT="0"

IUSE="+dbus hddtemp libnotify lm-sensors video_cards_nvidia"

COMMON_DEPEND="
>=dev-libs/glib-2.50:2
>=mate-base/mate-panel-1.17.0
>=x11-libs/cairo-1.0.4
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.22:3
hddtemp? ( >=app-admin/hddtemp-0.3_beta13 )
libnotify? ( >=x11-libs/libnotify-0.7 )
lm-sensors? ( sys-apps/lm-sensors )
video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools] )
"

RDEPEND="${COMMON_DEPEND}
virtual/libintl
"

DEPEND="${COMMON_DEPEND}
app-text/rarian
>=app-text/scrollkeeper-dtd-1:1.0
app-text/yelp-tools
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:2 ) )"

src_configure() {
local udisks

if use hddtemp && use dbus; then
udisks="--enable-udisks2"
else
udisks="--disable-udisks2"
fi

mate_src_configure \
--disable-netbsd \
--without-aticonfig \
$(use_enable libnotify) \
$(use_with lm-sensors libsensors) \
$(use_with video_cards_nvidia nvidia) \
${udisks}
}

0 comments on commit 40534cc

Please sign in to comment.