Skip to content

Commit

Permalink
media-libs/assimp: patch that fixes Findassimp cmake module path
Browse files Browse the repository at this point in the history
In default assimp installation there are hardcoded paths for /usr/local/lib
Reported in bug 595066

Reported-By: Patrick Nicolas <[email protected]>

Package-Manager: portage-2.3.1
  • Loading branch information
Slawomir Lis committed Sep 26, 2016
1 parent c39c747 commit 4053dbe
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 0 deletions.
5 changes: 5 additions & 0 deletions media-libs/assimp/assimp-3.3.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )
"

src_prepare() {
eapply "${FILESDIR}/findassimp-${PV}.patch"
eapply_user
}

src_configure() {
mycmakeargs=(
-DASSIMP_BUILD_SAMPLES=$(usex samples) \
Expand Down
25 changes: 25 additions & 0 deletions media-libs/assimp/files/findassimp-3.3.1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- a/cmake-modules/Findassimp.cmake 2016-09-26 07:52:09.719727490 +0200
+++ b/cmake-modules/Findassimp.cmake 2016-09-26 07:52:28.509727838 +0200
@@ -55,13 +55,13 @@
find_path(
assimp_INCLUDE_DIRS
NAMES postprocess.h scene.h version.h config.h cimport.h
- PATHS /usr/local/include/
+ PATHS /usr/include/
)

find_library(
assimp_LIBRARIES
NAMES assimp
- PATHS /usr/local/lib/
+ PATHS /usr/lib/
)

if (assimp_INCLUDE_DIRS AND assimp_LIBRARIES)
@@ -78,4 +78,4 @@
endif (assimp_FIND_REQUIRED)
endif (assimp_FOUND)

-endif(WIN32)
\ Brak znaku nowej linii na końcu pliku
+endif(WIN32)

0 comments on commit 4053dbe

Please sign in to comment.