Skip to content

Commit

Permalink
dev-java/commons-validator: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Sep 30, 2015
1 parent 916cb59 commit 4054642
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/commons-validator/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST commons-validator-1.4.0-src.tar.gz 222421 SHA256 e75554dbbe1681ccf3e556917a2311c509ff5c7fb9a473be03bdeb8215df5436 SHA512 35005d5ada8a1070cdd02f78464886e16157a05f895e3abfe2dcd51fa4b443d9ee359bb54a40e13ed463b757a77a64669c89cd9b914051a4ab1c745be3526d98 WHIRLPOOL 2932f8df70d9a89a51c218baac93fa5c199d0a2316147032416cba8f2100d29a508bc61603fc777eed7408b5bb265d40f4a7449354ec0227a8adf11471c4d8fd
DIST commons-validator-1.4.1-src.tar.gz 244155 SHA256 c3be9f4c717c78611b9e1590fc3a9932637190ccdcae642a0c54f84f5782388d SHA512 e64d16de2481c388c81a488dbe894c4d16a1abad12f841f6f77e2606013edbce75ec7a1371976b7e642adfc7cbc5038ff7271cb4d184fbeb32a635acf6bccb38 WHIRLPOOL bf2e214967a0dc94fb16fb2e90ccd6459807185e64fa2865196cbec5efae86d7cb7a04399158be4054a0a180dec96884ad56164abf49d74f49571ff904e9cfe4
82 changes: 82 additions & 0 deletions dev-java/commons-validator/commons-validator-1.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

JAVA_PKG_IUSE="examples source test" # doc

inherit java-pkg-2 java-ant-2

MY_P=${P}-src

DESCRIPTION="Commons component to validate user input, or data input"
HOMEPAGE="http://commons.apache.org/validator/"
SRC_URI="mirror://apache/commons/validator/source/${P}-src.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"

RDEPEND=">=virtual/jre-1.6
>=dev-java/commons-digester-1.6:0
>=dev-java/commons-collections-3.1:0
>=dev-java/commons-logging-1.0.4:0
dev-java/commons-beanutils:1.7"

DEPEND=">=virtual/jdk-1.6
test? ( dev-java/junit:0 )
${RDEPEND}"

S="${WORKDIR}/${MY_P}"

java_prepare() {
epatch "${FILESDIR}"/validator-1.4.build.xml.patch

JAVA_ANT_CLASSPATH_TAGS="javac java" java-ant_rewrite-classpath

echo "commons-digester.jar=$(java-pkg_getjars commons-digester)" >> build.properties
echo "commons-beanutils.jar=$(java-pkg_getjars commons-beanutils-1.7)" >> build.properties
echo "commons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)" >> build.properties
echo "commons-collections.jar=$(java-pkg_getjars commons-collections)" >> build.properties
}

EANT_JAVA_REWRITE_CLASSPATH="true"
EANT_GENTOO_CLASSPATH="commons-beanutils-1.7,commons-collections"
EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},commons-digester,commons-logging,junit"

EANT_BUILD_TARGET="compile"
EANT_EXTRA_ARGS="-Dskip.download=true"

src_compile() {
java-pkg-2_src_compile
jar -cf ${PN}.jar -C target/classes/ . || die "Could not create jar."

if use test ; then
eant compile.tests ${EANT_EXTRA_ARGS} -Dgentoo.classpath="$(java-pkg_getjars --build-only --with-dependencies ${EANT_TEST_GENTOO_CLASSPATH})"
jar -cf ${PN}-test.jar -C target/tests/ . || die "Could not create test jar."
fi
}

# Missing test suite org.apache.commons.validator.ValidatorTestSuite;
# therefore, tests can't be run.

# See https://issues.apache.org/jira/browse/VALIDATOR-323 for a bug report about this.
RESTRICT="test"

src_test() {
echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
eant test ${EANT_EXTRA_ARGS} -Dgentoo.classpath="$(java-pkg_getjars --build-only --with-dependencies ${EANT_TEST_GENTOO_CLASSPATH}):${PN}.jar:${PN}-test.jar"
}

src_install() {
java-pkg_dojar ${PN}.jar

dodoc NOTICE.txt RELEASE-NOTES.txt

# Docs are no longer generated, as they have commented them out;
# probably on purpose, since this is the start of a new branch.
# use doc && java-pkg_dojavadoc dist/docs/apidocs
use examples && java-pkg_doexamples src/example
use source && java-pkg_dosrc src/main/java/*
}

0 comments on commit 4054642

Please sign in to comment.