forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-session: Version bump
Package-Manager: portage-2.2.24
- Loading branch information
Showing
2 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST cinnamon-session-2.4.3.tar.gz 903363 SHA256 07afa992ae1c513b3a1e83a2fd29f83305f697dd45ba04121521ba8a7c005733 SHA512 318815e786f447237bceb08689eca5cf499c7fb0bd70b86c16f76af49e8f43c2a8c78e4caa96c0253a5e088702933ee53996286a8d4c2a68fa346832f12ec317 WHIRLPOOL 13e6c4d2e606484ad8fd290f195f9db4de6a9d09073b6bd8ae3c34af7786fee4aeff8a94e6aab03f5178c2721ec251d7fd2122fe1882002cfd4fdcf74c4624e8 | ||
DIST cinnamon-session-2.6.2.tar.gz 610789 SHA256 42ea718b77240ff24061203bc03ba6af7d51bcba2323b0bb73a56870e232cb92 SHA512 93b2caab5164de470794947a63dbb05a21f47c10d14df81f7563fac404be11423a7083e8e2aae20f41e4f43ae29bbb1131b5b1c56e2b2cc37aff0686a6d0c450 WHIRLPOOL e37b101665b49a7710237e63bb12634dc059cf56ba37b196cf24f6e6a2af7d9d6055005b646cb916fbbb47133c97c8126da76e2cd6c9f7845a529c2331886162 | ||
DIST cinnamon-session-2.6.3.tar.gz 612267 SHA256 391db79472cbd6c1546cec5e7e8e82f2a465fea92cda019fca14f7c54cfa4dc1 SHA512 91cf30dfd5fe7812c98d67233d54049ba11d04e142910f081a22bd48e2f0bbd0b4eeea4e66326628a0196c90164a146a2ef2ac61b26f289c17a0db8dbcc45a9b WHIRLPOOL f0841219624373c377e7f527b527682034d7b2519de105473395df87ab7aea3b130c5a45ad3141ca2fd4a1f523f3308b5af0e5409472e46131a6e68869134225 | ||
DIST cinnamon-session-2.8.2.tar.gz 591438 SHA256 0a7236c75fef67c1a1c173e184c083ff2879e870428bdc3cb53a892cb0bfaf79 SHA512 4f713cc5d9ec21bb118a2761792b1a86b43c386e0042f3f1c57ab6fa01fb7fd34463d83e63c794950dfe8358e757277a87d649340cda33f72fe4c89c7cf099bc WHIRLPOOL 6f202a79a27cdf6a8bbe1ed62d5b4a6c6edd5746b8b50a448fc8874cb5de4b45c4201e1bce25760072ee2874438e87505405810b45c7e10019fdbfc4c7cc9b6b |
72 changes: 72 additions & 0 deletions
72
gnome-extra/cinnamon-session/cinnamon-session-2.8.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="no" | ||
|
||
inherit autotools eutils gnome2 | ||
|
||
DESCRIPTION="Cinnamon session manager" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-session/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+ FDL-1.1+ LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc ipv6 systemd" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/dbus-glib-0.88 | ||
>=dev-libs/glib-2.37.3:2 | ||
media-libs/libcanberra | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3:3 | ||
x11-libs/cairo | ||
x11-libs/libICE | ||
x11-libs/libSM | ||
x11-libs/libX11 | ||
x11-libs/libXau | ||
x11-libs/libXcomposite | ||
x11-libs/libXext | ||
x11-libs/libXrender | ||
x11-libs/libXtst | ||
x11-libs/pango[X] | ||
virtual/opengl | ||
systemd? ( >=sys-apps/systemd-183 ) | ||
!systemd? ( >=sys-power/upower-pm-utils-0.9.23 ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=gnome-extra/cinnamon-desktop-2.6[systemd=] | ||
!systemd? ( sys-auth/consolekit ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
dev-libs/libxslt | ||
>=dev-util/intltool-0.40.6 | ||
virtual/pkgconfig | ||
doc? ( app-text/xmlto ) | ||
gnome-base/gnome-common | ||
" | ||
# gnome-base/gnome-common for eautoreconf | ||
|
||
src_prepare() { | ||
# make upower and logind check non-automagic | ||
epatch "${FILESDIR}/${PN}-2.6.2-automagic.patch" | ||
epatch_user | ||
|
||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
DOCS="AUTHORS README README.md" | ||
|
||
gnome2_src_configure \ | ||
--disable-gconf \ | ||
--disable-static \ | ||
$(use_enable doc docbook-docs) \ | ||
$(use_enable ipv6) \ | ||
$(use_enable systemd logind) \ | ||
$(usex systemd --disable-old-upower --enable-old-upower) | ||
} |