forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
eea3dcd
commit 4060d4e
Showing
3 changed files
with
244 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
78 changes: 78 additions & 0 deletions
78
dev-python/numpy/files/numpy-1.22.0-no-hardcode-blasv2.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,78 @@ | ||
Originally added in: https://gitweb.gentoo.org/repo/gentoo.git/commit/dev-python/numpy/files?id=e5ce90a04e79f6413604e96e4803cb95ada7c859 | ||
https://bugs.gentoo.org/567938 | ||
--- a/numpy/distutils/system_info.py | ||
+++ b/numpy/distutils/system_info.py | ||
@@ -502,36 +502,7 @@ def get_info(name, notfound_action=0): | ||
2 - raise error | ||
""" | ||
cl = {'armpl': armpl_info, | ||
- 'blas_armpl': blas_armpl_info, | ||
- 'lapack_armpl': lapack_armpl_info, | ||
'fftw3_armpl': fftw3_armpl_info, | ||
- 'atlas': atlas_info, # use lapack_opt or blas_opt instead | ||
- 'atlas_threads': atlas_threads_info, # ditto | ||
- 'atlas_blas': atlas_blas_info, | ||
- 'atlas_blas_threads': atlas_blas_threads_info, | ||
- 'lapack_atlas': lapack_atlas_info, # use lapack_opt instead | ||
- 'lapack_atlas_threads': lapack_atlas_threads_info, # ditto | ||
- 'atlas_3_10': atlas_3_10_info, # use lapack_opt or blas_opt instead | ||
- 'atlas_3_10_threads': atlas_3_10_threads_info, # ditto | ||
- 'atlas_3_10_blas': atlas_3_10_blas_info, | ||
- 'atlas_3_10_blas_threads': atlas_3_10_blas_threads_info, | ||
- 'lapack_atlas_3_10': lapack_atlas_3_10_info, # use lapack_opt instead | ||
- 'lapack_atlas_3_10_threads': lapack_atlas_3_10_threads_info, # ditto | ||
- 'flame': flame_info, # use lapack_opt instead | ||
- 'mkl': mkl_info, | ||
- # openblas which may or may not have embedded lapack | ||
- 'openblas': openblas_info, # use blas_opt instead | ||
- # openblas with embedded lapack | ||
- 'openblas_lapack': openblas_lapack_info, # use blas_opt instead | ||
- 'openblas_clapack': openblas_clapack_info, # use blas_opt instead | ||
- 'blis': blis_info, # use blas_opt instead | ||
- 'lapack_mkl': lapack_mkl_info, # use lapack_opt instead | ||
- 'blas_mkl': blas_mkl_info, # use blas_opt instead | ||
- 'accelerate': accelerate_info, # use blas_opt instead | ||
- 'openblas64_': openblas64__info, | ||
- 'openblas64__lapack': openblas64__lapack_info, | ||
- 'openblas_ilp64': openblas_ilp64_info, | ||
- 'openblas_ilp64_lapack': openblas_ilp64_lapack_info, | ||
'x11': x11_info, | ||
'fft_opt': fft_opt_info, | ||
'fftw': fftw_info, | ||
@@ -543,24 +514,12 @@ def get_info(name, notfound_action=0): | ||
'dfftw_threads': dfftw_threads_info, | ||
'sfftw_threads': sfftw_threads_info, | ||
'djbfft': djbfft_info, | ||
- 'blas': blas_info, # use blas_opt instead | ||
- 'lapack': lapack_info, # use lapack_opt instead | ||
- 'lapack_src': lapack_src_info, | ||
- 'blas_src': blas_src_info, | ||
'numpy': numpy_info, | ||
'f2py': f2py_info, | ||
'Numeric': Numeric_info, | ||
'numeric': Numeric_info, | ||
'numarray': numarray_info, | ||
'numerix': numerix_info, | ||
- 'lapack_opt': lapack_opt_info, | ||
- 'lapack_ilp64_opt': lapack_ilp64_opt_info, | ||
- 'lapack_ilp64_plain_opt': lapack_ilp64_plain_opt_info, | ||
- 'lapack64__opt': lapack64__opt_info, | ||
- 'blas_opt': blas_opt_info, | ||
- 'blas_ilp64_opt': blas_ilp64_opt_info, | ||
- 'blas_ilp64_plain_opt': blas_ilp64_plain_opt_info, | ||
- 'blas64__opt': blas64__opt_info, | ||
'boost_python': boost_python_info, | ||
'agg2': agg2_info, | ||
'wx': wx_info, | ||
@@ -951,10 +910,7 @@ class system_info: | ||
return [b for b in [a.strip() for a in libs.split(',')] if b] | ||
|
||
def get_libraries(self, key='libraries'): | ||
- if hasattr(self, '_lib_names'): | ||
- return self.get_libs(key, default=self._lib_names) | ||
- else: | ||
- return self.get_libs(key, '') | ||
+ return self.get_libs(key, '') | ||
|
||
def library_extensions(self): | ||
c = customized_ccompiler() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,162 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{8..10} ) | ||
PYTHON_REQ_USE="threads(+)" | ||
|
||
FORTRAN_NEEDED=lapack | ||
|
||
inherit distutils-r1 flag-o-matic fortran-2 toolchain-funcs | ||
|
||
# Not ready yet | ||
#DOC_PV=${PV} | ||
DOC_PV=1.21.0 | ||
DESCRIPTION="Fast array and numerical python library" | ||
HOMEPAGE="https://numpy.org/" | ||
SRC_URI=" | ||
mirror://pypi/${PN:0:1}/${PN}/${P}.zip | ||
doc? ( | ||
https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-html.zip -> numpy-html-${DOC_PV}.zip | ||
https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-ref.pdf -> numpy-ref-${DOC_PV}.pdf | ||
https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-user.pdf -> numpy-user-${DOC_PV}.pdf | ||
)" | ||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="doc lapack" | ||
|
||
RDEPEND=" | ||
lapack? ( | ||
>=virtual/cblas-3.8 | ||
>=virtual/lapack-3.8 | ||
) | ||
" | ||
BDEPEND=" | ||
${RDEPEND} | ||
app-arch/unzip | ||
>=dev-python/cython-0.29.24[${PYTHON_USEDEP}] | ||
lapack? ( virtual/pkgconfig ) | ||
test? ( | ||
>=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}] | ||
>=dev-python/cffi-1.14.0[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-1.22.0-no-hardcode-blasv2.patch | ||
) | ||
|
||
distutils_enable_tests pytest | ||
|
||
src_unpack() { | ||
default | ||
if use doc; then | ||
unzip -qo "${DISTDIR}"/numpy-html-${DOC_PV}.zip -d html || die | ||
fi | ||
} | ||
|
||
python_prepare_all() { | ||
if use lapack; then | ||
local incdir="${EPREFIX}"/usr/include | ||
local libdir="${EPREFIX}"/usr/$(get_libdir) | ||
cat >> site.cfg <<-EOF || die | ||
[blas] | ||
include_dirs = ${incdir} | ||
library_dirs = ${libdir} | ||
blas_libs = cblas,blas | ||
[lapack] | ||
library_dirs = ${libdir} | ||
lapack_libs = lapack | ||
EOF | ||
else | ||
export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None | ||
fi | ||
|
||
export CC="$(tc-getCC) ${CFLAGS}" | ||
|
||
append-flags -fno-strict-aliasing | ||
|
||
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573 | ||
# with the subtle difference that we don't want to break Darwin where | ||
# -shared is not a valid linker argument | ||
if [[ ${CHOST} != *-darwin* ]]; then | ||
append-ldflags -shared | ||
fi | ||
|
||
# only one fortran to link with: | ||
# linking with cblas and lapack library will force | ||
# autodetecting and linking to all available fortran compilers | ||
append-fflags -fPIC | ||
if use lapack; then | ||
NUMPY_FCONFIG="config_fc --noopt --noarch" | ||
# workaround bug 335908 | ||
[[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95" | ||
fi | ||
|
||
# don't version f2py, we will handle it. | ||
sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die | ||
|
||
# disable fuzzed tests | ||
find numpy/*/tests -name '*.py' -exec sed -i \ | ||
-e 's:def \(.*_fuzz\):def _\1:' {} + || die | ||
# very memory- and disk-hungry | ||
sed -i -e 's:test_large_zip:_&:' numpy/lib/tests/test_io.py || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile() { | ||
export MAKEOPTS=-j1 #660754 | ||
|
||
distutils-r1_python_compile ${NUMPY_FCONFIG} | ||
} | ||
|
||
python_test() { | ||
local deselect=( | ||
numpy/typing/tests/test_typing.py::test_reveal[arrayterator.py] | ||
) | ||
|
||
if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then | ||
# Degenerate case. arm32 chroot on arm64. | ||
# bug #774108 | ||
deselect+=( | ||
numpy/core/tests/test_cpu_features.py::Test_ARM_Features::test_features | ||
) | ||
fi | ||
|
||
if use x86 ; then | ||
deselect+=( | ||
# https://github.com/numpy/numpy/issues/18388 | ||
numpy/core/tests/test_umath.py::TestRemainder::test_float_remainder_overflow | ||
# https://github.com/numpy/numpy/issues/18387 | ||
numpy/random/tests/test_generator_mt19937.py::TestRandomDist::test_pareto | ||
) | ||
fi | ||
|
||
distutils_install_for_testing --single-version-externally-managed \ | ||
--record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG} | ||
|
||
cd "${TEST_DIR}/lib" || die | ||
epytest ${deselect[@]/#/--deselect } | ||
} | ||
|
||
python_install() { | ||
# https://github.com/numpy/numpy/issues/16005 | ||
local mydistutilsargs=( build_src ) | ||
distutils-r1_python_install ${NUMPY_FCONFIG} | ||
python_optimize | ||
} | ||
|
||
python_install_all() { | ||
local DOCS=( LICENSE.txt README.md THANKS.txt ) | ||
|
||
if use doc; then | ||
local HTML_DOCS=( "${WORKDIR}"/html/. ) | ||
DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf ) | ||
fi | ||
|
||
distutils-r1_python_install_all | ||
} |